Cant flash code via USB or OTA [Solved]

For the past day or so I keep getting a 500 error. I have emailed for support but no answer. This is very frustrating because I can no longer work on my project. I have tried clearing the cache, reset the token, cleared browser history, etc. Keep getting the 500 error. I have an electron.
Help please

Select the Devices icon (the circle with the lines, the target icon), then the Electron you want build for, click the “>” icon, and verify that the build with firmware popup menu has a valid value. The setting sometimes get set to something odd, which causes the Error 500.

If you have not upgraded the system firmware your Electron should have 0.4.8. There is a bug we’re trying to track down where some subset of new Electrons have 0.4.9 selected in the Web IDE by default, which causes an error 500.

Hey thanks for the reply. I looked and my device had 0.4.9 installed. I used the drop down to change it to 0.4.8 and the code compiled. Do I have to do anything to the device to change the firmware too?

You’re all set. The bug is that 0.4.9 gets selected sometimes. Since there was never an 0.4.9 for Electron, building fails when 0.4.9 is selected. Just setting the popup to 0.4.8 is all you need to do.


Thank you very much for your help. Crazy little things that drive you crazy. I appreciate your time.

1 Like

This just solved my problem, too:
Error 500 on both my Electrons until I flashed with 0.4.8

1 Like

Glad this post helped you out @douglaskbell!

1 Like