Error 500 when trying to download binaries, or flash Electron OTA

Hi guys, I’ve been working on an IoT project, prototyping it on a Photon, it’s now ready to go and ready to drop an Electron in to it, however everytime I try to download the binaries from the cloud IDE, or flash the Electron OTA it doesn’t download and says “Error: 500. Please try again later. If the issue persists, please report to”. It’s been happening for a few days now and doesn’t seem to be resolving. Has anyone else had this issue, or know of a work around? I’ve tried on Chrome, Firefox, and Edge all with the same error. Different projects, on different computers, still the same.

Hm–interesting. There hasn’t been any system-wide degradation of service to the IDE, so my guess is that it’s a local or browser issue. Have you already tried logging out and logging back in?

I just verified that downloading a binary works for me on OSX and Chrome.

Thanks for the reply Will, I had tried logging in and out, various network tests, but no dice. However after coming back after the weekend, it just downloaded the binaries successfully so hopefully it was just a random isolated issue.

Scratch that, the binaries downloaded once, the error 500 again, won’t flash OTA either, trying to get this project finished up.

Specified the issue to being when my Electron device is selected as the target device, changed it to a Photon and I can download binaries. Still can’t flash the Electron OTA.

Don’t mean to necropost, but I just set up my electron and I’m having the exact same issue. I set up my SIM first separately, I got an endless blue spinner when I tried to set up the SIM and electron at the same time.

There are two different issues:

Error 500 in Particle Build (Web IDE) can happen if the build for firmware popup menu has selected a version that doesn’t exist on the build server. For example, some Electrons have showed up as having 0.4.9 on the device, when they really had 0.4.8, which causes Error 500.

The Particle logo spinning after you enter your ICCID at is most easily worked around by switching browsers. You can switch back after activating your SIM. If you have an ad blocker that blocks your location you could also try disabling that; the setup process needs to know your location in order to provide the correct billing information and sometimes that gets stuck.

1 Like