Can't download the 3rd party SIM binary for Electron

I’m trying to do the firmware download. It would seem that the APN needs to be in double-quotes, or else clicking ‘download’ does nothing at all. Is that the case?

If I put the APN name in double-quotes, then when I click download, I get:

“ERROR: Could not download firmware binary from Particle servers. Please check your internet connection and try again.”

My internet connection is fine, since I am reading this forum and posting this message. Any ideas?

I have been testing this just about every other day and I always just type in broadband for my AT&T SIM, without any double quotes. What APN are you typing in?

This is a Google Project Fi SIM. If I type in “h2g2” without the quotes, absolutely nothing happens. If I add quotes, it does something: I get the error message.

That is very strange and I’d be interested to know what browser you’re using and if you get any errors in the console.

To get you connected, give this Google Project Fi (h2g2) Tinker a try:
https://dl.dropboxusercontent.com/u/41117656/firmware/tinker-h2g2-apn.bin

Flash with the Particle CLI command:
particle flash --serial tinker-h2g2-apn.bin

Can anyone enlighten me how to get to the above mentioned website? The documentation says “on the setup website” - the thing is I have no o2 reception at the place where I am right now, Particle choosed o2 as its partner in Germany - it just blinking green and I’m kind of stuck at the “claiming your electron” website.

I have however reception using another carrier - I also have a sim card to spare just no idea how to get to this website …

I am using Firefox 44.0.

When I put the APN in quotes, the firefox console gives me:

setupNotification { target: Window → setup.particle.io, isTrusted: false, detail: Object, currentTarget: Window → setup.particle.io, eventPhase: 2, bubbles: false, cancelable: false, defaultPrevented: false, timeStamp: 1455983782243000, originalTarget: Window → setup.particle.io, explicitOriginalTarget: Window → setup.particle.io } bundle.js:4:7396

Is the APN supposed to be quoted or not when you type it in the box?

I flashed the specified tinker firmware. Now the system boots, flashes green for 20 seconds, blinks some other colors, then ends up breathing cyan.

Then, I tried to do the rest of the setup. When I try to claim the device, the process fails with the following message:

Setup was unsuccessful
Your Electron failed to connect to the Particle cloud.
Please consult our troubleshooting guide for help.

I tried using Chrome to download, and it worked fine. Is there an issue with Firefox?

https://setup.particle.io I think is the place you are looking for?

It’s the big blue button that you see at the start of the Guide for the Electron when you go to http://www.particle.io/start

It’s not supposed to be quoted… just type in the APN and press download.

I don’t have firefox, but I’ll be sure to let the team know there is an issue with Firefox v44.0, thanks!

Since you now have reached breathing Cyan, please try to completely unplug power from your Electron for 10 seconds or so, and re-apply. If you get to breathing Cyan again, go through https://setup.particle.io once more and see if it claims it this time.

There is no big blue button, just 4 pictures explaining me what to do. Then I have to enter the long number from the sim card holder (it’s already activated), then another 4 pictures explaining me to wait until it is breathing cyan (which it never does), pressing next here just leads me to the “claiming your Electron” page…

Oh sorry I just meant the big blue button here (see gif below), that gets you to setup.particle.io

Which part are you stuck on when you say

Can anyone enlighten me how to get to the above mentioned website?

This sounds like the real problem you are trying to solve. I would say since your Electron is already running with a Particle SIM that’s activated, if it continues to blink green for more than 5 minutes you should go through the common issues for Blinking Green found here: https://docs.particle.io/support/troubleshooting/common-issues/electron/

If you get to step 11, please do write into support.

Unplugging/replugging always gets me back to breathing cyan, and the claiming process always fails. I tried again just now.

@mookiedog Hmm, can you try to claim it manually with Particle CLI?

First put your Electron in Listening Mode and run this to get your device ID

particle identify

Either reset your Electron or you can hold the MODE button for about 5 seconds then let go to exit Listening Mode. Wait for the Electron to breath Cyan, then run:

particle device add <device id>

If that worked, you can rename with:

particle device rename <device id> <device name>
1 Like

The thing is that I know that I don’t have any o2 coverage anywhere near so this might simply be the problem - I think i’ve got the right module for the european frequencies (that’s at least what’s stated on the package), I would like to create a Firmware for a Vodafone sim card but it seems I can’t change/create one, once I’ve entered the included sim card (I mean - entering the number, I don’t even know if the sim card is really activated as I can’t use it).
Seems like I have to contact support :confused:

Hmm, yes unfortunately that is going to be an issue. It might be worth traveling closer to some known coverage areas and powering up your electron to see if you get past the blinking Green.

The manual claiming process works. I tried it last night after searching the forums.

After the manual claim, the electron shows up in my list of devices in the particle cell phone app, but it shows up as being offline. It has been ‘offline’ all night long, even though the electron is powered, is constantly breathing cyan, and shows me 2 bars of signal strength when I push the ‘mode’ button.

Hmm, yeah I just tried that myself and I’m not seeing my electron online in the app. If you use particle list or the Build IDE though you should see it online. However, when you switch it off it will still show up online. This is because of the connectionless UDP protocol we are using. Once we make a connection with the server we don’t ping the server every 15 seconds like we do with TCP on the Photon/Core, so there is no way to know the device is offline. That said we are still working out how to indicate online/offline vs last-heard or ways to check/update the online status. You should be able to use the app though, I have reported this issue to the mobile team.

Thank you!

@mookiedog just wanted to update you on the Particle App issue. We have located and resolved an issue that was preventing the app from detecting your Electron’s online status. If you refresh your devices on the Particle App, you should see your Electron online now and be able to control it with Tinker.