Can't connect to our network

I’m trying to connecting a Photon (one of 20 that I’ve bought for an upcoming class) to our internet. It’s failing. I can connect to my personal hotspot using WPA2, but when I try and connect to the university using WPA2 and AES, it fails, and then can no longer connect back to the personal hotspot. The Photon ends up blinking yellow, about 3 times, then cyan (about a minute), a bit of green, another minute of cyan, and then the cycle repeats.

I really want to be able to use this in my class, but I am seriously stuck … any help would be greatly appreciated.

Is this a very rapid three blinks of yellow (or maybe orange/red)?
If so, try particle keys doctor <insertDeviceID>

But the green in between does puzzle me a bit, so could you also try to replace the USB cable and make sure the power supply is good clean 5V DC.

Could you post a video of the color codes?

What I see are 3 slow yellow flashes, and then a whole bunch of cyan and green ones. This happens a) after I’ve hit the reset button, or b) after I’ve tried to connect (it always fails to connect). The movie is here

Our university is working with WPA2 AES and WPA2 TKIP – do you think that’s part of the problem? At home, everything works just flawlessly …

It’s not red but this would fit the bill
https://docs.particle.io/guide/getting-started/connect

And you say 19 other Photons can connect to the cloud via this network just this one can’t?
Or have you only tried this one?

Can you make sure the CoAP port 5683 is open?
And your uni doesn’t use a captive portal?

Thanks, ScruffR, for all your help.

I’ve tried 2 Photons so far, and neither could connect: both could connect at home. I had not heard of CoAP ports until you just mentioned them … are there any other ports that need to be open? I’m not sure about a captive portal, but I will make inquiries right now.

Nope, CoAP should be the only one “special”.
Other your actual application might need for outbound TCP/UDP should be checked on-demand.

Captive portal: Do you need to provide an extra password or tick a checkbox when you first connect a new computer/phone to that network?

I’m just waiting for my Networking Guru to get back to me on the CoAP question.

Interestingly, particle setup does tell me “> It looks like your Photon has made it happily to the cloud!”, but it really hasn’t: I get the 3 slow yellow flashes, many fast cyan and a few fast green flashes, instead of the cyan heartbeat.

I dunno if that sounds symptomatic of a CoAP problem, but that would be awesome if this fixes the problem!

Does it say cloud or internet?

If it is what I expect then your device got successfully hooked up on the WiFi but can’t call home, but the app only seems to look for the first part to shout “success”.

A captive portal would prevent you from communicating with anything else but the AP/portal and the port would just hinder the cloud connection.
If it’s only the port, you could try SYSTEM_MODE(MANUAL) with WiFi.on() and WiFi.connect() to see if you can get to breathing green and at least use TCP/UDP communication.

Here’s the complete transcript (I especially like the bit where I win the internet :grinning: ):

Obtaining device information…
Setting up device id xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Requesting public key from the device…
Setting the magical cloud claim code…
Telling the Photon to apply your Wi-Fi configuration…
The Photon will now attempt to connect to your Wi-Fi network…

Configuration complete! You’ve just won the internet!
? Would you like to return this computer to the wireless network you just configured? Yes
It looks like your Photon has made it happily to the cloud!

! PROTIP: Your Photon may start a firmware update immediately upon connecting for the first time.
! PROTIP: If it starts an update, you will see it flash MAGENTA until the update has completed.
? What would you like to call your photon? Trouble

Your Photon has been bestowed with the name Trouble
Congratulations! You’ve just won the internet!
Ok, bye! Don’t forget particle help if you’re stuck! <3

I do note that the name Trouble does appear in build.particle.io, so that piece of the communication puzzle (it’s a puzzle to me, anyways) is in place.

So, to conclude … CoAP was key! Thank you again, ScuffR, name your favorite charity and I’ll send a donation in your name!

On a related matter, it might be nice to include a mention of this in the Troubleshooting guide …

1 Like

It is here https://docs.particle.io/support/troubleshooting/connection-help/core/#can-39-t-get-connected (see STEP 4)

But for some reason this is only shown for the Core and not the Photon.
Thanks for pointing me to that :+1:


Update:
I’ve just filed a PR to the docs that should make this visible for Photon too.
This should come online soon here
https://docs.particle.io/support/troubleshooting/connection-help/photon/