Can't connect to cloud - flashing cyan

Hey @derdude41065 and @Sku; have you both completed all the troubleshooting steps?

http://docs.spark.io/#/connect/troubleshooting

Hey Zach, everything aside from manually updating the firmware. Stuck on a compiling error (any ideas?).

Edit, extra info: Tried adding the gcc/lib paths to environment variables.

@Sku you don’t actually need to build the firmware yourself; you can just use the binary that’s already in the github repository. See these instructions:

1 Like

Thanks @zach Zach, updated the firmware now and the issue persists sadly.

Hmmm… so it’s flashing cyan? Does that mean that it flashes blue, then you send your Wi-Fi credentials, and it switches to green and then to cyan, but doesn’t go to breathing cyan?

@zach HTML5 GIF or YouTube of the exact lights for you.

@zach yes, tried every step multiple times. The Core talks talks to amazon cloud service (think there is the spark cloud hosted?), watched through tcpdump. And the light is definitely flashing cyan.
Power on, flashing green and when connected to wifi flashing cyan and remaining in that state. Thanks for your help.

@Sku and @derdude41065: Go ahead and email me your Core ID at zachary@spark.io. We’ll get your Cores up and running.

Just jumping in here, but I think fast flashing cyan usually indicates problems with the public server key on the core. Flashing orange (yellow/red) indicates problems with the core-key I believe. If it’s the server public key, then we need to re-write that key to the core.

dfu-util -d 1d50:607f -a 1 -s 0x00001000 -v -D cloud_public.der

You can grab that key here:
https://s3.amazonaws.com/spark-website/cloud_public.der

Instructions for updating private keys here:

Updated the server key to no avail, zachary just mentioned in email that my core ID isn’t showing up on your end. Will keep you posted.

1 Like

Got the same advice vom zachery, but still no change.

I have the exact same problem, can’t configure via wifi and when setting the wifi credentials over usb it leads to the flashing cyan state.

the hint from a mail conversation with zachery to patched the cc3000, get’s me a step closer to fast flashing orange light (handshake error)

All resolved for me.

After running through all of these troubleshooting steps I proceeded to follow @Dave’s steps over here to generate a new key for the core.

Thanks again to @zachary for all the help.

Hi All

I’m something of a newbie but I’ve managed to patch the cc3000 and also re-written the cloud_public.der certificate as per @Dave’s instructions above. I am still experiencing the fast-cyan-flashing problem despite all of these steps.

I’m a little concerned about running the instructions against the yellow/red flashing light issue as this is not what my Spark is doing and it seems to be rather drastic.

I have not got to the point that @derdude41065 got to (i.e. a handshake error) either.

Any ideas?

Hi @abrown007 ,

Nice! Glad you got the patch installed (copied the firmware, held down the mode button until it blinked magenta, then waited until the light turned solid, then flashed back the normal firmware?). Can you email me your core id at david@spark.io ? I can check the logs and see if your core is showing up with key problems.

Thanks!
David

Hi David

Thanks for your quick response. I was rather pleased with getting that patch installed and did exactly as you’ve just described (i.e. magenta, etc). I just PM’d the ID and saw that you said to email it to you - sorry!.

I will await your response - thanks again for looking into this for me.

Andy

Hello,

I’ve managed to do some different tests and ended up with different results.

I could update the firmware to use https://github.com/spark/cc3000-patch-programmer it reached the solid magenta state but didn’t boot anymore afterwards.

Updating to https://github.com/spark/core-firmware I assume it worked properly as when configuring the wifi via USD it asked a new question about the security schema. But this end up having an alternating state between flashing red and flashing cyan.

Should I try to reset the private key?

@earakaki flashing red/cyan actually means that it’s having trouble connecting to the global network (it’s on your Wi-Fi network, but it’s not getting to the Cloud). Do you have a good internet connection to your Wi-Fi network?

Hi. Just in general. I’m seeing something similar. Not got a video of the lights just yet bit I’ve done several factory resets and readded my wifi credentials successfully over the iPhone app.

The core powers up. Connects to wifi and then does a few different things each cycle (seemingly randomly).

  1. Flashes cyan rapidly.
  2. Hold solid cyan
  3. Flashes cyan once

It then power cycles and does the above again.

I haven’t managed to connect up via serial yet to see what’s going on (sounds like the server key issue). I downloaded coolterm onto my iMac but can’t seem to find the core as a serial connection. only Bluetooth modem and Bluetooth incoming are options.

Does anyone have any suggestions?
This all stemmed from a flash via the web IDE.