Can't compile due to Makefile

Hi all,

I have suddenly gotten a error when I try to compile my program:


make[1]: MyUserName.particle\toolchains\buildscripts\1.15.0\Makefile: No such file or directory
make[1]: *** No rule to make target 'MyUserName.particle\toolchains\buildscripts\1.15.0\Makefile'. Stop.
make: *** [C:\Users\MyUserName.particle\toolchains\buildscripts\1.15.0\Makefile:95: compile-all] Error 2

  • The terminal process "C:\Users\MyUserName.particle\toolchains\buildtools\1.1.1\bin\bash.exe '-c', 'make -f 'C:\Users\MyUserName.particle\toolchains\buildscripts\1.15.0\Makefile' compile-all -s'" terminated with exit code: 2.
  • Press any key to close the terminal.

(I have replaced my name with 'MyUserName')

I'm new to this device but I have gotten a few program to run without any error. Now my new program and the previous ones won't compile. Does anyone have a way around this error and perhaps get the compiler to create the Makefiler again?

I'm using Visual Studio Code with the Workbench extension. I have tried to uninstall both and reinstall them.

I'm running an Argon which is connected via USB and the LED is "breating cyan" which should indicate that it is running & ready for compile + flash.

I would first try Particle: Configure Project for Device and reselect your Device and Device OS version.

If that doesn't work, try Particle: Install Local Compiler Toolchain.

You could also try cloud compiling instead of local compiling using Particle: Cloud flash which is generally much easier and faster, especially with the Argon.

1 Like

Thank you for your reply !

I tried Particle: Configure Project for Device and Particle: Install Local Compiler Toolchain and both fully processed both the problem remains - it won't compile! It gives the same error code as before.

I tried Cloud compile which is able to compile & flash the Argon but I can't see any messages printed in the console with the Serial.printf("Hello World") command. But I have a test project where I send data to a Thinksspeak project and this project does recieve data from the Argon so it must work in some sense.

I tried to read some of the info from:

Troubleshooting the Particle Workbench | Troubleshooting | Particle

And from this link

The "arch" does indicate an x86 on my end and that is not support as I understand it. But how to I change that to something that works with the Argon?