Local Compile Stopped Working (Workbench)

I’ve been working on and compiling a project half the day and now the local compiler has mysteriously stopped working.

I am getting the following error (particular file has changed but is now stuck on globals.cpp)

Executing task: make -f ‘C:\Users\vdw.particle\toolchains\buildscripts\1.9.2\Makefile’ compile-user -s <

:::: COMPILING APPLICATION

make[3]: *** No rule to make target ‘c:\work\11589\src\globals.cpp’, needed by ‘…/build/target/user/platform-6-m/11589/src/globals.o’. Stop.
make[2]: *** […/…/…/build/recurse.mk:12: user] Error 2
make[1]: *** […/build/recurse.mk:12: modules/photon/user-part] Error 2
make: *** [C:\Users\vdw.particle\toolchains\buildscripts\1.9.2\Makefile:54: compile-user] Error 2
The terminal process terminated with exit code: 2

I have opened other projects and they are compiling without error so I don’t think it’s the makefile. I’ve also rolled back to commits that I know compiled previously and they don’t compile now.

I think there is something wrong with the project setup, but I cannot figure out what.

settings.json
{
    "extensions.ignoreRecommendations": true,
    "C_Cpp.default.configurationProvider": "particle.particle-vscode-core",
    "files.associations": {
        "*.ino": "cpp",
        "*.tcc": "cpp"
    },
    "particle.firmwareVersion": "1.0.1",
    "cortex-debug.openocdPath": "${command:particle.getDebuggerOpenocdPath}",
    "particle.targetDevice": "11589"
}

I am also using some Particle Libraries and a file I was working on used one of these libraries (ITEADLIB_Nextion)

project.properties

name=11589
dependencies.clickButton=1.0.9
dependencies.ITEADLIB_Nextion=0.0.16

Have you tried the clean task?

3 Likes

That worked! Thank you!

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.