Cannot setup, security NONE issue

My Photon was working fine but then I moved to a new house. I need to setup the Photon so it works with my new router.

My house can see a half dozen wifi networks. Three of them are from my house. (Don’t ask why I have three.)

  1. BlueMoose Security: WPA2 Personal
  2. BlueMoose-guest Security: None
  3. xfinitywifi Security: None

ALL THREE require a password from the user when he first attempts to use the network. I assume the password needs to be stuffed into the Photon as a part of the setup process so it can use the network later on.

I tried both the smartphone and CLI app named ‘particle’ Both seem to lead to the same problem dead end. ‘particle’ tries the automagical way of doing thing and attempts to find what wifi nets exist, ask you which one you want to use with the Photon, and use whatever security is sees is already in use by that network.

If I select either of the wifi nets which are listed as “Security: None”, it appears to decide that, since it’s NONE, why bother asking the user for a password? There is no place in the dialog where one can enter a password. Output follows.

I chose not to use the WPA2 Personal network because the password is quite long and complicated. I also have not yet tried to use “manual” setup but I think the program should not need it.

I am missing something about passwords and their use with wifi.


? Would you like to manually enter your Wi-Fi network configuration? No
? Please select the network to which your Photon should connect: xfinitywifi
> Here’s what we’re going to send to the Photon:

> Wi-Fi Network: xfinitywifi
> Security: NONE
> Password: [none]

The password you’re talking about, does that appear on a webpage after you’ve connected, a so-called ‘captive portal’? If that’s the case, then I’m afraid that won’t work. The complicated WPA2 however, should work.

Security NONE means no-password to encrypt the communication so why would you want to enter an encryption password - unless you actually have a captive portal (as @Moors7 already asked), then read this

1 Like

Well, once again my thanks to ScrufR and Moors7, my two favorite forum responders (because they provide the answers!).

I had never heard of captive networks. The dumb user (AKA, me) knew about passwords at the generic level: “A password gets you in.” But I did not think that there were two different types of passwords: WPA2 passwords and captive portal passwords.

Thanks. Please continue to help people drowning in the sea. My tally of owing you another beer is mounting.