Cannot flash Photon

Background: I have been using the Particle Photon to successfully monitor and operate my garage with Blynk for a number of months.
I was attempting to switch from the Blynk cloud to a Blynk server using a Raspberry Pi. I was able to switch to my Pi server and operate my garage door with the Blynk app on my iPhone and iPad but could not do it outside my wifi.
Abruptly I could not compile my code via IDE. This ended up being (I assume) the RunningMedian library being locked out for some odd reason (a ticket has been submitted). Once I changed to the RunningAverage library I was able to compile, but still not flash.
Upon powering up the Photon will breathe Cyan and then after 10 seconds (or 5 blinks) it goes to green, breathing at the same rate.
I went on CLI, put device in DFU mode and updated system firmware.
I tried to flash “blink an led” with no luck.
I can see the device power down on
I have reset my token on the IDE after I was having this trouble. I tried to use ‘Particle Keys Doctor’ to correct and got ‘openssl is not recognized as an internal or external command’ error.
Any ideas ?

You can try Safe Mode to flash OTA.

OpenSSL needs to be installed on your system and be accessible from any directory (in Windows added to the PATH environment variable)

You issue with losing connection is due to some blocking behaviour of your (or Blynk) code.


I treated the Photon as if it was new unit. After going through the setup, I flashed the “Blink an LED” via web IDE and it worked. I then flashed the original code (removing the Running Median portion of the code) and it worked.
Thank you for your help ScruffR.

1 Like