Cannot flash or verify in Particle Dev: "Please open a directory with your project"

Whenever I click on the Verify or Flash buttons, I get this message. The project in question is saved and has .ino extension. What am I doing wrong?

Can you relaunch Particle Dev and open the directory again to see what happens?

Forgive me for the silly question but which directory? The project files are saved at a particle folder I created earlier in Documents. I’m confused, what directory am I supposed to open and how?

For Particle Dev you need to have each project in its own folder, which only contains one .ino file and only .h/.cpp files.
If you have other files or subfolders in there, you need to create a spark.ignore (or particle.ignore??) file that lists all the files/subfolders to ignore.

And once you have set your file structure like this don’t use Open File ... but Open Folder ... to load your project.

Can the particle dev be used as the Arduino IDE? Do I have to create .h/.cpp files in order to use it? I guess that must be the problem.

1 Like

Not as an Arduino IDE, but you can edit Arduino files just the same.

No, you don’t have to create .h/.cpp files. If your project just needs one .ino file that’s fine too, but it has to live in its own folder.

So I created a folder and within the folder I saved a file (Documents/Particle_folder/BLINK/blink.ino). I still cannot verify or flash the code, I still get the same ‘Please open the directory…’ message. I’m going mental. What’s happening? Why can’t I use a simple IDE? Have I done something wrong?

Have you really used this to open your project?

There’s no Open file or Open folder, just Open (Mac OS X). I tried restarting the Particle Dev then ‘Open’ the file (no option to open folder). UPDATE: there’s an ‘Add Project Folder’ option, tried that and didn’t make any difference. I feel like crying.

Something else I checked: the device is online and available (Photon) and shows up in ‘Devices’ and is selected.

OK, since I’m on Win I can’t help you with that version, sorry.
But it’s odd that the two versions are not the same :confused:

I genuinely appreciate your help, thank you! I’m so frustrated and have no idea what to do:(

Mine works fine…

Can you hit the folder button on the left taskbar and open the .ino file?

Yes, I can.

I have the same issue on Mac OS X 10.10.5.
There is no “Open Folder” nor does clicking “Add Project Folder” help.
Please help. Thank you!

Does the Mac verion have a Cmd+Shift+O shortcut as the Windows version has?
What other options do you find in the File menu (screenshot :sunglasses: )?

1 Like

On the Mac version, you just click File -> Open... or the folder icon on the left.

Do not use Add Project Folder... that is an Atom (the editor on which Particle Dev is based) feature that does not have a use in Particle Dev.

2 Likes

Ok, first of all thank you both for your comments.
Sadly I wasn’t able to flash with both of your advices. Any other ideas?
(and yes, ScruffR, CMD+Shift+O exists, but doesn’t help either. Nor CMD+O (Open File) does.

Are you sure you’re on the latest version of Particle Dev? Also, do you mind taking a screenshot of the whole window?

1 Like

Yes, I am, sir. :wink:

Full window: (just noticed: path in the top window bar seems odd. Isn’t it?)

1 Like