Cannot flash from WEBID [SOLVED]

Cannot flash firmware
Core flash magenta solid for about 3-5 seconds, than goes cyan flashing and breathing cyan again with old firmware.
Hoped on writing some interesting code today and now I cant flash :frowning:

Not sure what might be the problem. But having some similar problems in the past, a factory reset seemed to fix it most of the time. Kind of a pain in the *ss to have to reset it every couple of flashes, but it seemed to work. Let’s hope that a wired flashing option will come available soon for quick tests, and fast development.

Factory reset helped, but that is annoying

And after flashing it I can’t reflash again :frowning:

Can you share your code?

I can’t as many changes happened already and new code reflashes nicely. Took me few factory resets to make OTA work again with my firmware.

I guess it is combination of active usage of TCPClient, polling Spark.variable and using noInterrupts for i2c/OneWire connections.

Current code does the same but uses TCPClient less frequently and OTA reflash now goes fine.

ok cool! I’ll mark this one as solved

Is this really solved? i have the same problem. I wrote Firmware to make the LED on the bord flash… and now i cant write any other code to it.

1 Like

@CNBurger can you share your code? Were you able to recover it through a factory reset?

You might need to do a factory reset, and try flashing then. Since your code runs alongside the Spark code that keeps your core online, it’s possible right now for bugs to knock the core offline. Resetting to the factory default ensures you’re using known stable firmware when connecting to the cloud, and should allow you to do another OTA update.


worked fine after the reset thanks

1 Like