Cannot connect via Putty on Kubuntu


i want to connect to my spark core via putty on my Kubuntu-Laptop. But it seems, the core is not detected properly. lsusb lists an openmoko-device which i suppose to be the core. But i cant get any other serial device as ttyS0 and ttyACM0 with “dmesg | grep tty”.

How to solve the problem?


Its me again.

i tried using a XP-Virtual Machine to connect with putty to my spark. But it didnt work. I just got a black terminal window.

Whats wrong?

This device is the device present if you want flash your spark-core. To do this you need dfu-utils under ubuntu. If you want access serial function of the core. Make something like this in your code

void setup()




void loop()
Serial.println(“hello world”);


This will create a ttyACMX device under ubuntu.

as i wrote, ther ist an device /ttyACM0, but there is nothing than a black screen when i try to connect to this via serial. I tried also to connect with the iPhone- and Android-App. It was less sucessful.The Tinker-App works, but i cannot use the cloud-IDE.

may be you need to change serial param to 8 N 1 9600

@klofisch Is your Core in ‘listening mode’ (flashing blue LED)? If not, hold the MODE button for 3 seconds, and it should show up as a serial device.

hey Guys,

i had read the manual allready,…its really strange why it’s not working with my Windows nor Kubuntu-PC. Also when i try to set it up with my IPhone i can use the tinker-app. But the core is not shown in the cloud-ide. All i want to know is the Device-ID. Why cant it be shown in the app?


i got connected to the core via serial and the id. But when i entered the id in the web-ide to claim the core, nothing was happen. Just the request for the id appeared again. This is really disgusting!!!

Hey @klofisch,

/dev/ttyACM0 should work on linux for talking to the core over serial. I usually do something like “minicom -D /dev/ttyACM0 -b 9600”

It sounds like you were able to connect and hit “i” to have the core give you its id if you entered it on the website? It’s also important that your core be online when you try to claim it. Can you confirm it’s connected to your wifi and breathing cyan? Did the “claim a core” prompt give you any errors? If not, and you’re on Kubuntu, what browser / version are you using?

If it’s breathing cyan and you have the core id, can you email me ( / your core id, and the email address you’re using on your account if you have it?


Sorry to all. U were right, i got connected all time, but i thought there is an error, because no info appeared.

@Dave i emailed u my id because i couldn’t claim the core with the id either.

1 Like