Cannot connect Electron using 3rd party SIM (so-net in Japan)

Hi,

I received Electron and it is working nice with Particle SIM in Japan.

Now that I’ve got a local SIM with good data plan deal, I’m trying to connect with it but Electron keep blinking green and does not connect. I’d appreciate any advice.

The SIM I’ve got is So-net 0 SIM. They offer monthly 500MB for free and additional data at JPY100/100MB. Should be a dream deal for low traffic IoT devices :wink:

Here’s APN info I received from the provider.

APN: so-net.jp
Username: nuro
Password: nuro
Authentication type: CHAP or PAP

I was not sure how to set APN with username and password at the setup page thus followed this instruction to use STARTUP macro.
https://docs.particle.io/reference/firmware/electron/#setcredentials-

Here is the source code:

#include "cellular_hal.h"
STARTUP(cellular_credentials_set("so-net.jp", "nuro", "nuro", NULL));

int led1 = D0;
int led2 = D7;

void setup() {
  pinMode(led1, OUTPUT);
  pinMode(led2, OUTPUT);
}

void loop() {
  digitalWrite(led1, HIGH);
  digitalWrite(led2, HIGH);
  delay(1000);
  digitalWrite(led1, LOW);
  digitalWrite(led2, LOW);
  delay(1000);
}

Compiled it and flashed it with command:
particle flash --usb firmware.bin

With So-net 0SIM card, the Electron keeps blinking green and does not connect to network…

Commenting out the STARTUP macro line, compile and flash, the Electron with Particle SIM connects to the network alright so I’m sure the HW setup is ok.

I’d appreciate any advice. Does Electron support Authentication type: CHAP or PAP?

As a prerequisite for the use of cellular_credentials_set() you need to go back to setup.particle.io,enter your third party SIM, follow the instructions for 3rd party by downloading and flashing a dedicated firmware version.

Only after that your above code can do what you expect it to do.

Hello,
I go to ‘setup.particle.io’ and tried to download firmware.
But ‘ElectronActions.js:243 OPTIONS https://api.particle.i/v1/binaries net::ERR_NAME_NOT_RESOLVED’ error occured on Safari and Chrome browser.
Is it a typo on setup page?

Thanks for your advice, ScruffR!

Oh, I didn’t know I had to go through setup.particle.io even to use STARTUP macro. I wanted to skip it for three reasons.

  1. So-net didn’t give me exact ICCID number.
    Well, I saw somewhere in this forum that I could use 12341234123412341234 to move on but I was not sure if ICCID is embedded in the dedicated firmware.

  2. Cannot find a way to specify Username and password
    In the APN textbox, I understand I can put APN name, so-net.jp
    But I wondered how to specify username and password… maybe they are not needed. But I could not find anything mention it.

  3. Cannot download firmware for ERR_NAME_NOT_RESOLVED
    I used 1234 fake CCID and put so-net.jp as APN name. But hitting “DOWNLOAD” button didn’t start download… I faced the same error as m_hash says. I tried also with Safari and Chrome.

I have created an issue on GitHub for this typo

But STARTUP() will still be available even without this, I’m just not sure about the credentials settings to stick without that firmware.

Hello shunya
If you use iPhone, you can see ICCID at setting app. I don’t know Android is same.

Thank you, ScruffR!
I will try , too.