Cannot connect Argon WiFi PSK network

Hello I have problems connecting my Argon to a WiFi network. From the customer end they tell that my Argon is trying to connect using 802.1X, which is weird because it should only be able to connect using WPA2 PSK. From the cloud debug software I can see the following going on.

This is on 3.0.0 and cloud debug software pulled from the latest master branch.

0000027825 [app] INFO: Still trying to connect to Wi-Fi 00:10
0000037687 [ncp.esp32.at] TRACE: < +CWJAP:3
0000037688 [ncp.esp32.at] TRACE: < ERROR
0000037688 [ncp.esp32.mux] INFO: Mux channel 2 already opened
0000037689 [ncp.esp32.client] TRACE: Connecting to "iotroam" (no security)
0000037825 [app] INFO: Still trying to connect to Wi-Fi 00:20
0000047825 [app] INFO: Still trying to connect to Wi-Fi 00:30

Do you have any idea what could be the cause

Is there a captive portal on the iotroam SSID? Something that requires you to agree to access terms before accessing the open network, for example? The Argon will not be able to connect to the network in that case.

Also if that’s not the network that’s intended, it could be left from old credentials. Holding down MODE until the status LED blinks dark blue then continuing to hold it down until it blinks blue rapidly, then releasing will clear all credentials, then you can set the correct credentials again.

Just had it checked by the IT department of the customer and it seems there was an configuration error on their side, although they did not tell me what it was. Thanks for taking the time!

1 Like