Can not connect to Wifi, LED blinks red, cyan and yellow

I have tried every thing I am sure except the one thing that needs to be done to make it work, after I open the app an put in the credentials this weird LED behavior starts

I have tried it on two different networks and changed the settings on my router and all that… currently it is set to WPA2(AES), b+g+n 2,4GHz, channel 4, chip antenna, bought in late June this year

Can you try putting the router to bg networks only, the core cant do “n” networks.

the flashing looks very fast, is it sped up at all in the video?

Hi Hootie81,

thanks for the reply,

I have already tried setting it to bg with no success…

yes it is blinking very fast, the video is not sped up no

@Dave Does this look like a keys issue? everything just seems very very fast? and the red flashing at 20 seconds seems really fast, then it looks like it tries to restart, reconnects to the wifi instantly and then connect to the cloud in half a second then bad keys (red/yellow) and maybe another hyper speed SOS?

Hey All,

Yup! That’s a bad keys issue, sorry!

We have an article on how to fix your keys here:


Apparently I didn’t find a DFU device? util said
Make sure your core is in DFU mode (blinking yellow), and that your computer is
Error - no dfu device found.

I get this error (even though the LED is blinking yellow after holding the mode button for 3 sec after taping the reset button while holding mode)

Hi @Mquist

If you are on Windows, there is a driver.

If you are on Mac or Linux, you may have to use sudo dfu-util… depending on how your permissions are setup.

Also you need a USB 2.0 port (or hub). USB 3.0 ports have been known to be a problem.

thanks… the dfu command is now working, but… I get error on step 8, when I enter spark keys doctor **********

It starts to do something and says NEw Key Created! but then it says I couldn’t find the file: *****************_new.der

**************=my device id

my computer is online and I am logged in and the LED is blinking yellow

Try spark keys doctor core_id and be sure you are running the command from a path that files can be saved. :slight_smile:

thanks kennethlimcp

getting closer…

the command did work but now it is flashing green and then once every 34 seconds or so it gives one breath of cyan.

Try performing spark flash --usb cc3000 followed by spark flash --usb tinker

Both commands are to be called in DFU mode.

The first command will perform a patch to the CC3000 firmware and should blink magenta while doing so and eventually revert to blinking once it’s done!

You are getting close. :wink:


after the spark had been sitting for 30 minutes or more it all out of sudden started breathing cyan, and I could upload a “hello world” sketch to it, blinking an LED on 1 sec interval and it did reconnect after the upload, but when I uploaded again, after changing the interval it would not connect back again, so I tried what kennethlimcp suggested but with no luck (well what kennethlimcp suggested did all work, performing the patch and flashing with tinker but still the spark is just blinking green, and one breath of cyan once in a while)

It might be the WiFi credentials security type issue… might… :smiley:

There was a user who had similar issues and it was a security type setting that was the issue.

Try performing a factory reset and send in credentials again?

Hmm, yeah this would indicate a lot of trouble keeping a connection open, I would make sure the core has the right cc3000 patch, is running the latest firmware, and that you have a good antenna connected / the core isn’t wet, etc. :slight_smile:

I’ve also seen firmware updates to the wireless access point help sometimes, in case you have any updates pending for your WiFi router.


not sure what the problem was but I reseted my router to factory settings, then cahnged the PW and SSID on the router back to what it was and now it all works!! :smiley:
you can mark this as solved!! :wink: thank you guys