Fast blinking - 25 sec yellow - 25 sec red - 2 sec cyan - No WIFI

I tried updating the firmware but whether or not it took was unclear. Seems to match the issue peterlee​0127 was having at one point. I can’t access the core through the USB com when it is in this state. Any thoughts?


Is is a new core that never connected successfully to Wifi?

When you say updating firmware, you mean downloading new code to the core?

I would recommend doing a factory reset to clear things out :smile:

@kennethlimcp yep I tried a factory reset several times. Each time it fails and enters this same cycle of lights right after I enter the wifi credentials. And this core has been connected before but I had an issue where I was getting no lights at all except for D7 when I would hold down the reset.

Hmmm…that sounds like the rainbow sequence but maybe not :slight_smile:

So what’s the end colur?

There doesn’t seem to be an end color it goes into an endless loop in the sequence I mentioned in the title of the thread.

What are you using to send wifi crendentials? Can you check if the core is claimed under your account?

It sounds like the rainbow sequence, waiting for the core to be claimed…

Can you send a video of the LED pattern that you’re seeing? It may be easier to debug if we can see it directly

It’s the same as without the initial green sequence. The cyan appears to be the start of the sequence followed by yellow then red and then the pattern starts over. I will post a video this evening. Thanks for the assist guys.

1 Like


If you are certain it’s the same sequence but without the blinking green at the start, it simply means that the core is unable to handshake with the :spark: cloud due to bad keys.

Hi @jberendes,

Sorry about the delay in getting back to you, if your core is doing the light pattern in the video you sent, then it’s having a problem with its keys.

I posted about this problem here:

I hope that helps!