Can Boron be used to recieve and send SMS?

I believe the problem is that Cellular.command isn't supported on the Boron yet.

1 Like

Well, that would certainly explain it! Is that documented anywhere, and are there plans to support it in the future?

1 Like

On another thread, @rickkas7 pointed to the source code (it’s not supported on the Boron):

int cellular_command(_CALLBACKPTR_MDM cb, void* param, system_tick_t timeout_ms, const char* format, …) {


So, for now at least, the answer to the question “Can Boron be used to receive and send SMS?” is “no”

1 Like

Thats really a problem…

Is there any date to provide access to cellular. command? Who is the right person to ask?

I notice that SMS is not officially supported on the Boron, nor is it supported on the Auduino MKR NB 1500. Common thread? Both use the u-blox R4 modem, which, according to the u-blox docs, is SMS capable. So…

  1. The R4 modem defaults to numeric response codes, instead of text. The U260 defaults to text codes. Change it with an AT command at the top of your app, and all would be well, if cellular commands were enabled (not yet, I know).

  2. I edited the Arduino GSM SMS library (used on the MKR 1400) to work on the in the MKR NB 1500. to my utter amazement, SMS reception worked! Until it didn’t. And when it didn’t, it locked up the entire modem, the board, everything. Full power cycle required to restart. So I wasn’t really surprised – in retrospect now – to see that SMS is not enabled on the Boron LTE as well. My guess: the modem is buggy, and since it’s pretty much the only one out there in Cat-M1/NB world, companies like Arduino, Hologram (for the Nova modem) and Particle are limited in their choice.

  3. This modem also has an issue opening a TCP socket consistently (needed for uploading data to Hologram). This seems tied to the SMS issue; removing my admittedly amateurish SMS library, and more importantly, all references to the code seemed to stabilize the TCP issue. Still, if the modem disconnects, which happens during holograms frequent backend maintenance intervals, self reconnect does not seem to take place (and, yes, I’ve tried various methods – Even the reset button won’t do it, it seems to want a full power cycle to re-connect).

A little bit of searching on the Arduino forms, u-blox forums, etc., will show that this thing seems a bit buggy.

I very much want/need incoming SMS, using third-party SIM on the Boron LTE. It looks like I will be waiting a while! :slight_smile:

1 Like

With next pre-release Cellular.command() will be implemented.

1 Like

@michaelm I assume you’re talking about the U-Blox Sara R404, which was a bit of a beta release and only usable on Verizon. The R410 seems much more stable. Or are your woes with an R410?

Sadly, yes, my issues are with the R410. Apologies for my not being accurate with the model number.

Firmware is current on the Auduino MK1500; have not yet formally checked the R410 on the Boron, but it was shipped fresh from the Particle Store this week.

I’m able to connect Cat M on the Arduino 1500 to AT&T here in Michigan (Detroit area) no problem.

The R410 having issues is not good to hear :-(. I guess only time will tell how reliable it is in the operating modes used by particle…
Is there a ublox forum thread that describes some of the issues? Or did you open a ticket directly with ublox?

There is some chatter on the Hologram and u-blox forums about related issues. The conversation includes modem users, as well as board users (Arduino, Particle), so it’s a bit hard to discern a consistent thread / issue. Not a lot of people have their hands on these modems yet, and only some of those really have a big need for SMS. I’ve had the Boron just under a week now (!), so I’ve started here to see what’s known / understood about the issue. Looks like I’ll be joining the u-blox forum as well.

EDIT: Added reference to Hologram support community. Hologram users and employees do try hard over there! :-). u-blox support community seems like users only – no company support that I could discern.

Ah, yes, of course! I should have added that I’m looking for SMS functionality when using an SMS-capable SIM, like Hologram’s. I currently use a Hologram SIM on an Electron 3G – the combination works very well, including incoming SMS (for command processing, which is why I need it).


Yes - the Cellular.command() user API should essentially give you access to the u-blox modem’s full list of supported AT commands.

1 Like

Has anyone tried sending text messgaes with a Boron(recently)? Supposedly Cellular.command() is implemented in 0.9.0 and it does seem to do something. Unlike the previous versions where it always returned -120 (not implemented, the AT+CMGF=1 returns -2 (OK). But the AT+CMGS= seems to cause the device to crash (it never sends any data and can’t be pinged until it is power-cycled, though it is still breathing cyan)

I have the same issue with the same u-blox R410 modem & firmware, but on the Arduino MKR NB 1500.

Modem works mostly OK (also locks up sometimes when trying to create an outbound TCP socket to Hologram). See my earlier posts. ^^^

There is also this post to check:

Activating any SMS command on this modem on the Arduino (also done via AT commands, as you have) seems to quickly hang the modem, and a full power cycle is required to set things right. Adding the Idiot’s Kludge (delays) at various points in the program seemed to help, but only sometimes / sporadically.

My Grand Conspiracy Speculation: I cannot help but wonder if this issue is partly to blame for the delay in the Arduino’s 1500’s release from the North American Arduino Store, and why there is still no community support for this board on the Arduino community forum. The Arduino MKR NB 1500 has been announced as “coming soon” since May of last year.

For the record, I tried it again with 1.2.0-beta1, and it’s still not working for me. Calling Cellular.command with AT+CMGF=1 hangs the boron on until it is power cycled.

Hi I hope it is Ok to resurrect this topic. I’m wanting to use SMS with an Australian provider’s Sim to control some home electronics. I’ve been using Arduino Programing language for a few years and Have been hopeful as I move toward different hardware to build this project I have just received my Boron LTE and Hope that this LTE Board will be able fit my purpose. I’m hoping the issues have been resolved since then.


Welcome to the community! I hope you find the help you need here.

You could accomplish your objective using a 3rd party service. For example, when my Particle cellular devices send data to Ubidots, there is an events engine that sends and SMS (or Slack, or Telegram or email) based on the value.

Similarly, you could use a service like Twillio which you publish a webhook to that would do the same thing (link posted above).

Would this type of solution work?


What I am wanting to do is to send a message to to a box of electronics eg “Air OFF” and the box will send an IR message to my Air Con to turn it off so I’m not wasting electricity then on my way home in the Afternoon in Summer when the Temperature is 40C+ (38C =100F) I can go “Air ON” when I’m 1/2 hour from home and I won’t have to wait too long for the temperature to be comfortable. sending a SMS from my phone to an Australian Number is basicly free with most phone deals in Australia while every MB is charged so sending SMS from my phone to the boron if this can not be done I will be looking for a way to use the Boron as a 4G Modem for my DIY Raspberry Pi (4) based Laptop. If I wanted to do messages from phone to the Box of electronics Via a website I wouldn’t have used a boron I would probably have just used a wifi add on board or module if I need to use a web service for telling my home electronics to do stuff then It will not be via the mobile phone network that is much more expensive than via an unlimited Broadband Data I have at home.

Just for the record, I tried this again with 2.01. Calling Cellular.command with AT+CMGF=1 hangs the boron on until it is power cycled (even though it is stil breathing cyan you can’t ping it or send it any commands)

Answer to the question in the title directly, with the answer I wish I would have gotten when I first joined the platform: No.

It is not supported and in my experience it does not work reliably. Use the suggested 3rd party services.

1 Like