Breathing magenta for hours after 0.4.6 update from Particle Dev


#1

I used Particle Dev on my Mac to update my Photon. I added a space to a line to force the recompile and expected it to get the new 0.4.6 update. It blinked Magenta for quite a while, then went solid Magenta. I did some resets and it would blink green seem to connect and then breathe magenta for a long time - like over an hour. I tried doing resets over and over; no difference.

Today I decided to try the update from the Web Dev with a blink program. That had a number of magenta blinking patterns and eventually my Photon came up. I could then go back to Particle Dev and push my own firmware down to the Photon.

For some reason the update via the Particle Dev environment didn’t get the job done.

Jim


#2

This article explains how to get the system updates - Particle Dev is not one of the supported methods at present. Particle Firmware Updates Thread

Sorry it’s like this and that we even need this kind of list of exceptions - our offering is a bit fragmented in places regarding how system firmware updates work and what compiler versions are used. I’m asking internally to get both CLI and Dev on feature parity with the Web IDE regarding version selection and updating system firmware as part of compile. The back-end services are also being radically overhauled to fix this problem so that the device is given the system firmware update when it is needed, no matter how the new application firmware came to be flashed.


#3

Thanks. Now that I know that Particle Dev doesn’t do it, that helps.

It would be an improvement if the Particle Dev didn’t try to flash the new firmware and thus fail. Sure it would be great to update the system firmware from Particle Dev, but just avoiding failure would be a big improvement.

Thanks again,
Jim