Both Photons blinking rapid cyan after first program flash

I have set up two Photons successfully - both breathing cyan and were found by the Web IDE. I used my iPhone to set them up. They are both 0.4.3. I have named them and claimed them. I tried Tinker and could get the little blue (D7) LED to blink. No problems there.

Here are the problems with both: When I tried to flash a simple program, the flash failed and the Photon began rapid blinking cyan. I believe this means they can’t access the Particle cloud. I’ve seen other explanations that this means they’re updating. There is no way to confirm this. When they are powered up, I get a momentary white, then slow blinking cyan then rapid blinking cyan which stays that way.
Also, it appears that there is no factory reset button or buttons on the Photon. So, they are both useless and I have spent two days on this problem.

Here is what I have done: Tried for hours to install CLI on my Windows 10 laptop and still it doesn’t work. I followed the instructions for Windows 10 CLI Installer and found the instructions really really confusing. There are missing words in some sentences like there was some attempt at editing. I can do a particle login from the Windows command prompt but nothing else. There is no npm executable.
Also, I tried to get both Photons into the LISTEN mode which it should indicated by blinking blue. I held down the Setup button for a long time and on one, the blinking cyan changes to steady non-blinking cyan. On the other, the blinking cyan goes dead - no light at all. If I can’t get them into Listen mode, then CLI won’t do me any good even if I could get it to work.

My questions: Is there any straightforward way to determine if they are defective? Are there any step by step methods documenting how to setup CLI on a Windows 10 computer? Is there really no factory reset method on the Photon module? Are the Photons obsolete by now and I should be using another Particle product? Is there a way to flash the firmware without having to use CLI?

Thank you for any help.

Have you tried Safe Mode?
Since you mentioned Tinker worked but the issues started after you flashed your simple code, I’d assume that’s the problem. Even simple programs can hinder the system from doing the cloud stuff.
This assertion is also backed with the mention of “steady non-blinking cyan” and “no light at all”, when trying to force the device into Listening Mode while your code is running.

npm would be a separate installation (along with nodeJS) but that shouldn’t be needed with the CLI installer.

What do you get when you try anything else? Knowing that would help diagnosing your issue.

Not quite, you can probably put the device in Safe Mode and then into Listening Mode or you could use DFU Mode all along.