Boron - "particle serial inspect" returns "Could not inspect device: Memory allocation error"

I have a fairly new Boron (Device OS: 4.0.2) that until recently has been working just fine (I've been testing DHT sensors). I set it aside for about a week to work on something else. When I returned to work on the Boron, I noticed a few strange things. When I plug it in the USB port, it breathes cyan, and shows as online in the console as well as command line via "particle list". The "Last heard" and "Last handshake" in the console show current timestamps, but all other attempts to communicate with the Boron fails. I've tried Ping and Signal, and they both return "The device was unreachable by the Particle cloud within 15 seconds."

Any attempt to flash, upgrade, etc. via the command line fails. For example, when I try "particle serial inspect" on the command line, I get the following error:
%particle serial inspect
Device: e00fce683ec2aa070cf01e7c
Platform: 13 - Boron

Could not inspect device: Memory allocation error

For reference, "particle serial inspect" works just fine on my other Boron and a Photon.

Any ideas on what might be causing this, or other suggestions for troubleshooting? Thanks!


One thing I failed to mention in my original post was I also couldn't get the Boron into listening mode.

On a whim, I tried the "particle serial inspect" command immediately after hitting reset, and that worked. I then held down the mode button immediately after hitting reset, and that also worked and I got the device into listening mode. From there I was able flash tinker (particle flash --local tinker), and now the Boron is working just fine. I suspect I had bad/corrupted code running on the device and it prevented anything else from working.

I may have posted my problem too soon, but I think writing everything down helped me think through the problem a bit more.


This typically happens if your user firmware does not return from loop, especially if you are not using SYSTEM_THREAD(ENABLED).

It's recommended that you do both of those things to prevent the cloud connection from stopping.

Thanks, @rickkas7. I'm going on vacation tomorrow, but I'll test this when I return.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.