Bootloader 2300 not performing properly on one of my P2's

I have two P2's. They both have been upgraded to 5.5.0 using the device restore tool with the Chrome browser. One P2 shows that all is well when connected. The other shows that the bootloader system-part1 is also at 5501 but has a red X next to it. I have reflashed the device forcing everything to be flashed even if it thinks it is correct, but I still get the red X.

Also, when the device boots up it goes into listening mode with a constant blue flashing led. Is this 2nd P2 damaged or am I missing something?

Here is the good P2 report

And here is the report from the failing P2

@Support can you please take a look.

There appears to a bug in upgrading the boot loader on the P2/Photon 2 using using Device Restore USB. It goes through the step properly, but the update does not take and the bootloader does not get upgraded.

The reason for the red x in your picture is that the bootloader was not upgraded. It was 2100 (5.3.0) and 2300 (5.5.0) is required. It's not a problem with the system-part, it's a problem with a dependency of the system-part.

I tested a Photon 2 by downgrading it to 5.3.0 using Device Restore USB. That appeared to work properly.

I then cleared the Wi-Fi credentials by long press of MODE. This is not a necessary part of upgrading, but it assures that the bootloader will not be upgraded OTA before it can be noticed.

I then used Device Restore USB to upgrade to 5.5.0 which appeared to work properly as all of the steps including the bootloader step progressed normally.

However when I used Device Inspect the boot loader was not in fact upgraded.

My guess is that if a device has working Wi-Fi the upgrade of the bootloader happens so quickly you don't notice it happening.

Workarounds include:

  • Use which uses a different technique for upgrading the bootloader
  • Use the --local flash option in Workbench or the CLI which also uses a different technique.
  • Flash the bootloader manually in --serial (listening mode) using the CLI.
  • Enter Wi-Fi credentials so the bootloader can be upgraded OTA.

Thanks Rick. I will try these options you provided. As any FYI, I tried adding my wifi credentials to this device and was also unsuccessful getting the following error.

particle serial wifi --json credentials.json
! Something went wrong: Error: Resource busy, cannot open /dev/tty.usbmodem2102

Make sure you don't have another serial connection open to the device, such as particle serial monitor as that will prevent particle serial wifi from working and cause that error.

My photon 2 is just connected via the usb and the firmware on board, I believe, is tinker from a previous flash. I run into this now and then in my classes with certain students and never quite understand how to fix it.

Also, using worked great. The Photon 2 is now working properly. Thanks Rick.

1 Like

Fixed a bug in Device Restore USB on the P2 and Photon 2 (RTL872x) where if both prebootloader-part1 and bootloader required an upgrade, the bootloader might not upgrade (even with the flash even if version unchanged option is set). This was most noticeable if upgrading a P2/Photon 2 to 5.3.0 with no Wi-Fi credentials so the bootloader would not upgrade OTA.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.