Boot loop new core [Resolved]


I’ve just manually updated three of my four cores to the latest firmware using dfu-util on ubuntu successfully.

I’ve just fired up the last one, and it looks like I have a boot loop.


(1)flashes white for 3 seconds
(2) solid blue for 1 second


I’ve tried doing a factory reset, but I can’t get that to work (it won’t go to the flashing yellow stage).

Any ideas anyone?


okay, looks like it stopped boot looping, and it now giving the little blue led of no firmware. Since I can’t force it to factory reset, I’m thinking its bricked.

nope, no JTAG assets here.

1 Like

It’s hard to brick a core. :slight_smile:

Can you perform a factory reset again? Did you see a rapid flashing white on the RGB led?

Be sure not to mix up the 2 buttons. :slight_smile:

If it’s really faulty we can always get it replaced but let’s troubleshoot first.

1 Like

That’s the problem, it won’t do a factory reset.

Do you have a video to show us what’s going on?

1 Like

That’s odd. The fact that the RGB is showing something indicates that the bootloader should be running. I’m thinking it might be bootloader states being messed up by the constant rebooting.

An example the bootloader could set USB_DFU_MODE from a failed update causing the RGB LED to not change color after 3 seconds of holding the user button:

else if(!USB_DFU_MODE && TimingBUTTON <= 7000)
			// if pressed for >= 3 sec, enter USB DFU Mode

Have you tried: holding reset, holding user button, release reset twice while user button is held?

Also in the video it looks like you only hold user button for 8 or 9 seconds. Factory reset should kick in after 10 seconds.

1 Like

That looks rather weird.

Maybe you can drop an email to and give them your details + reference to this thread for a replacement.

1 Like


usually it goes to dfa mode after a few seconds (yellow blinking). Considering this is out of the box from Spark, and I haven’t done anything to it, I’m going to go for the replacement offer below.

Thanks for the input!

@sparkus @kennethlimcp that actually looks to me like a tricky problem to diagnose…I believe this is an issue with the CC3000 failing to boot up correctly (boot loop), and in addition one of the LEDs of the RGB LED on the Core (red) is also defective, so the LED displays cyan instead of the traditional white.

We’ll get it replaced for you–look for an email in the next 5 minutes from the support team. Looks like you’ve got one of the originals!


got the email from will, and a replacement is on its way.

Thanks for the quick response from the Spark Team!