Blynk lib for photon

I read similar post but solution wasn’t complete. I’m using a simple example for blynk it works great in WEB IDE 6.1 photon. When I move it to DEV. No luck compile times out.

  1. I used the library manager add library. it adds a line to properties file dependencies.blynk=0.4.7. but my blynk references all generated errors.
  2. There are no clear instructions on whether or not the #include statement is required and if should have “” or <> tried every combination and no luck. there is also some confusion as to is it Blynk.h or blynk.h or is that even significant?
  3. tried copying the library using library manager. that was a loser as the examples included had compile errors (keepAlive for Electron). Why should I be compiling other examples? It can’t be this hard. I must be on wrong track. Help.

Either way should work now.

That’s a known issue that’s on the back log.
To get a copied library to build in Dev or CLI you need to delete the examples folder.

For your 1. point I’d have to check, but I guess it’s due to some issues with the recently added Arduino compatibility features that get in the way of explicitly Particle ported libraries.
With CLI and Web IDE you can target 0.6.0, 0.6.1-rc.1 or 0.6.2-rc.1 which might help you get on with your project till 0.6.2 will be officially released which should consolidate the compatibility issue.

Thanks for quick response. I tried deleting example. They are protected and WIN10 wouldn’t let me delete or edit error in lib my project folder. How do I get around protection to delete examples folder?
Update: tried 0.6.2-rc.1. I was able to delete blynck examples folder from my new project all 0.6.2-rc.1. have #include <blynk.h> as first line. Still get compiler timed out in dev? This a rather major roadblock. I’m sure I’m not the only one trying to use Blynk.
Why doesn’t the rest of my #include line appear in above?

Because <...> is interpreted as HTML tag.
To make it show up you need to “escape” this way

This is some `<tag>` that should be shown

I have edited your post accordingly.

BTW, I suspect your delete protection was only temporary due to some program (e.g. Explorer or cmd) having a grip on the directory.