"Blink An LED" program not working

I have 2 cores, both do exactly the same thing.

The core gets to the breathing cyan state. I forked the “Blink An LED” program and didn’t change anything. I click “Flash” in Build and the core starts blinking magenta. Eventually it stops and restarts. Blinks green, then cyan, then breaths cyan again. It seems to me like the flash worked, the only problem is the program is not running. There is no LED flashing.

Other things to note:

  1. In Build sometimes it never stops saying “Compiling…”, and sometimes it gets stuck saying that is is taking longer than normal and to be patient. It says this even after the core has stopped flashing magenta.
  2. A couple times while I was trying it they did get stuck on solid magenta. But clicking the restart button restarted it and it did the whole process again eventually getting to the same result: breathing cyan but no blinking LED.

Help is much appreciated.

In order to make the internal LED flash, you should be using this code:

Void setup(){
RGB.control(true); //enable on-board LED control
Void loop(){
RGB.color(0,125,125); //RGB value on
Delay(1000); //wait 1 second
RGB.color(0,0,0); //RGB value off
Delay(1000); // wait 1 second

I couldn’t tell from your post if this is what you wanted to do, but it’s at least useful for testing LED code without any extra hardware.

Did you connect the led to the right pin?

One of the examples use the D0 pin, another uses D7 (the onboard led).

Alright, now I feel like an idiot. I had assumed that the onboard LED was attached to D0. Changed the pin to D7 in the code and it works now.


ok i am a dumb newbie, i cant get led’s to flash.

dumb q - you plug the led into th two holes adjacent to the pin eg d0 = I21/J21 on the breadboard.