Argon Flashing Cyan (running on 0.8.0-rc.26)


#1

Hi -

I set up the Argon via the Android app two weeks ago, connected and was on my way. I uploaded a sketch and it worked great. I switched the device back on this week and the device seems to have trouble connecting to the cloud.

I have since set up another Argon and it does not have this issue, but I noticed under ‘Build’ there is no option for 0.8.0-rc.26. When I set up the Argon two weeks ago I believe I updated to this firmware version, but now it is not available. This is leading me to suspect that perhaps the reason I am unable to connect to the cloud has to do with this version of the firmware potentially being revoked, and now the device is unable to connect as it has firmware which it ‘shouldn’t’ have?

Any advice appreciated.


#2

@iotpete, though the 0.8.0-rc26 tag appeared, the IDE was not actually compiling against that version. So you have rc25 on those devices. Particle is working feverishly to get rc26 ready which is expected very soon.


#3

Thanks for your hard work. I’m not in a hurry for the new firmware, but trying to understand why the device is now unable to connect to the cloud. I’ve since deleted and unclaimed the device and gone about a fresh initialisation, but am running into the same issues that the device will not manage to make a connection to the cloud. It appears to verify the WiFi password, flashing green then quickly moving on to flashing cyan, not able to reach the ‘breathing’ cyan state.


#4

@iotpete, there are been numerous posts about Argon WiFi issues, most of which are related to router configurations. The rc26 release will fix most if not all of these issues.


#5

Understood. I’ll stand by for the new firmware. Anecdotally I do have one connected and one not connected here, so perhaps it is just a little fickle. Also - how does one update the firmware on a device when said device is unable to connect to the cloud?


#6

Hey folks – wanted to follow up here to let everyone know that v080-rc.26 has been released which includes a handful of improvements that address setup reliability, wireless range between devices, and Mesh stability.

Instructions for upgrading are available here – would love to hear your feedback on the update and whether or not it resolves your connectivity issues:


#7

I’m still suffering with the same issues. I ran a factory reset, unclaimed the device from our account and still have the same issue with the device refusing to get past the ‘Starting a secure session with the Particle Device Cloud’ part of the setup process.


#8

Can you try a different network?
Flashing cyan would inidcate that WiFi is connected and the device tries to call home but can’t get a proper handshake. A possible reason might be a firewall restriction to UDP port 5683.
Usually a mobile phone hotspot should let that through.


#9

I’ve tried multiple networks, and actually I have another Argon which is behaving itself on the same network, so I was thinking maybe is it something to do with authenticating the device?


#10

That could be possible. It might be that the handshake is failing as a result of bad keys rather than a release-wide issue with rc.26 or rc.27. I’ll invite @mstanley and @ParticleD to jump in to see if they can’t resolve this issue with you.


#11

Hey Pete,

I agree with @will and would say this sounds like a keys issue. Would you be able to provide me with the device id (you are welcome to provide it here, in DMs, or through a support ticket) so that we can take a look further into this?

Thanks!


#12

Hi - so I deleted and unclaimed the device from my account as part of my troubleshooting, so I don’t have the device-ID available on the console. How does one find the device ID through another means?


#13

You can use CLI particle serial identify to request the device ID directly from the device.
Or if you don’t have CLI installed (which would be good to have in any case) you could use a serial terminal program and send i (identify).
Both ways require the device to be in Listening Mode (blinking blue).


#15

I am also experiencing the same problem and have not been able to get connected to the device cloud. I have the Argon and when i go through the setup it flashes slowly green, then fast green, then slow cyan for 5 or 6 flashes and then starts flashing rapidly, App says “Starting a secure session with the Particle Devices Cloud” and never gets passed. My device ID is e00fce68cb90eb69d421b3d2. I am connecting through iphone hotspot and have tried with android hotspot as well as my wifi. Any help would be greatly appreciated as this is very frustrating. Oh, and I also updated to rc.26.


#16

Quick update…

My issue did appear to be the key. I ran “particle key doctor” for my device id and once it rebooted I was able to get connected and get started using WEBIDE. Very excited and can’t wait to get started on my project.


#17

rc.27 is the version to use.