Argon - Error Running Script - Constantly "Looking for Internet"

Hello everyone. I am pretty new to the Particle ecosystem. I am trying to flash my Argon board with scripts directly with a USB connection and through Particle Workbench. I am unable to connect the Argon to WiFi due to restrictions with my campus internet policies.

Is there a way to prevent the Argon from searching for internet and just function as an offline device that executes the uploaded firmware?

Hopefully that makes sense. Let me know if I need to clarify my problem in more depth. Thanks!

SYSTEM_MODE() and SYSTEM_THREAD(ENABLED) would be the terms of interest.

Yes, it’s possible!

  1. Particle Support | System Modes
    Use SEMI_AUTOMATIC or MANUAL
  2. Set SOME sort of wi-fi credentials. Even dummy ones are fine. They don’t have to be valid.
  3. Ensure USB setup done is set, too: Command Line Interface (CLI) | Reference Documentation | Particle

Thank you for your assistance. I got it to work.

1 Like