Any way to recover non-responsive Xenons?


#1

I have now essentially bricked 2 Xenons. Both have the same behavior:

  1. the CLI can “identify” them when they are flashing blue, but the setup command fails, unable to find them:`
>particle identify

Your device id is *********************
Your system firmware version is 0.8.0-rc.27

C:\AppData\Local\particle>particle setup
 _ __             _   _      _
| '_ \  __ _ _ __| |_(_) ___| | ___
| |_) |/ _` | '__| __| |/ __| |/ _ \
|  __/| (_| | |  | |_| | (__| |  __/
|_|    \__,_|_|   \__|_|\___|_|\___|
                 https://particle.io

> Setup is easy! Let's get started...
> It appears as though you are already logged in as ******@**
? Would you like to use this account? Yes

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet.


C:\AppData\Local\particle>
  1. the dfu-util cant find them when they are put in dfu mode

  2. the particle debugger can flash the bootloader and it verifies correctly, and it can flash the firmware, and the softdevice.hex

I’ve tried the factory reset button combo, which flashes the correct pattern described in the docs for a reset, but at this point I can’t get them to do anything but flash blue.

What have I missed?


#2

I don’t know if CLI setup will work for a Xenon because there is no internet connection. Are the Xenons in a stand-alone configuration in an Ethernet shield? The workflows to do CLI config for mesh haven’t been released yet as far as I’ve seen.

When in dfu mode, do they show up in device manager? (Assuming windows.) If they show with a warning explanation point then you have to apply the drivers manually using the zadig tool.

IIRC, the factory reset memory slot is empty unless you explicity flash a user firmware to that slot. Therefore, the factory reset doesn’t do anything on a factory-fresh mesh device.


#3

Nope, particle setup is not meant to work for Xenons (yet - don’t know if ever).


#5

In the original description of the issue, I neglected to say that they flash blue but won’t pair with the android app. That was actually why I tried the debugger and the CLI


#6

In that case, after attempting to pair in the android app, and it fails, copy the debugging log contents (menu at top right of android app) and paste them here or into a support ticket.