Analog Input Slider in Tinker Freezing upon input [SOLVED]


I am completely new to Spark and am having some trouble with my iOS Tinker App. When using Analog Write to control the RGB LED, the sliders seem to freeze a lot when trying to use the slider to put in a new value, especially 0 or 255. Here is a screenshot of the slider freezing when I tried to move the value to 255:

I have to tap somewhere else on the screen to close the analog slider and then open it again. I closed the app out of my iPhone’s memory and tried again but the problem still exists. I can’t find anything on this forum that mentions this.

Has anybody else experienced this before?

Thank you!


1 Like

I deleted and re-installed the iOS Tinker App on my iPhone and now it works fine.


Hi @sljenk,

Weird, thanks for sharing? How long ago did you install the app, was it around 90 days? I wonder if this is just the app not behaving well when the access token expires?


My first install of the app was only about a week ago. My access token was valid and Tinker was still connected to the Spark Core. The analog input worked some of the time–maybe got stuck about 50-75% of the time.