After flashing firmware, unrecoverable hard fault, cannot boot into safe mode

My Photon device cannot boot into safe mode. I can only boot it into DFU mode after waiting. I tried flashing Tinker to it via DFU, and it still hard faults after it’s done, though the DFU flashing appears successful. It happened after I tried flashing Voodoo by copying and pasting the source into the web IDE. The previous firmware was working fine. It does not connect to the Internet, it immediately hard faults when powered.

Try clearing the credentials by holding SETUP for 10+ sec till you see rapid blue flashing.

In order to enter Safe Mode, do you release SETUP as soon as you see the first magenta flash?

If you can get your device into DFU mode (flashing yellow) then you can use these commands to reset the firmware on the device:

particle update
particle flash --usb tinker

That should refresh the system and user firmware on the device and eliminate the hard fault issue so you can resume development.

@will, he’s already tried that, I think

I’m thinking that reflashing the system firmware might be a necessary first step, since it is hard faulting during the connection sequence.

@concerned have you already tried reflashing the system firmware using particle update?

I’m having the same issue here, combined with a few others.

I have a custom board with a P1 that has worked fine in the past. Was able to connect to wifi, claim etc.

Butm I noticed it wasn’t working with our SoftAP setup web app like normal, so I decided to do a firmware upgrade, starting with just flashing tinker to trigger the latest one.

After particle flash --usb tinker the device went into constant blinking cyan. After some research I assigned new public keys. Twice. No dice.

Also manually upgraded firmware to the latest with .bin files in dfu mode. No dice there either (or with previous versions).

Not just trying to get into safe mode doesn’t even work. When I let go of the setup button it essentially resets and goes right back to blinking cyan.

Very stumped!

That’s normal, since the device needs to get connected to your WiFi and the cloud first (going through blinking cyan) in order to end up breathing magenta.
So you just can’t get onto the cloud for some reason.

Do you see any other colors during the blinking cyan phase?
Has anything on your router/firewall changed? (e.g. CoAP port 5683 closed)

1 Like

Oh hey, yes that makes total sense about the safe mode then.

No other colors sadly (if you’re thinking about the random red flashes people see with the need to reset keys, I’ve never seen that happen - and I’ve been staring at this thing for the past hour or two).

On random thing - in the 0.5.3 firmware, the blinking pauses for a split second every so often but then continues. In 0.5.2 this does not happen. But I imagine this is just a new thing in the firmware about looking for other networks or trying to reconnect.

At first I suspected just that - it was a network thing. But then I cleared stored credentials and set it up to just my phone’s hotspot, and even that didn’t work (i.e. back to blinking cyan, never getting to the rapid flashing and then breathing). I never noticed my phone registering someone getting onto it’s network (which I imagine might happen even if just in cyan blinking vs. breathing).

Really appreciate the thinking here - hit me with the next thoughts!

It’s most likely not the WiFi as such, otherwise you’d be stuck in flashing green.
Maybe try a different power source or USB cable since ripples on the DC might also interfere.

Agreed - thinking it’s something funky low-level. Just not sure what or how to address beyond the obvious.

All this has been while plugged into my computer (lots of quality DFU mode time spent). Just tried in a couple other sources to no avail.

I have the same problem. My Rom was working fine, I flashed a modification to it to control the brightness of the LED and upon reboot it starts to flash red.
I can get it into DFU mode, but besides that - nothing.
When I place it in DFU mode and do the “particle update” - I get this message:

Then it reboot and goes directly into flashing red again. The flashes are too fast for me to determine the amount of flashes. I cannot distinguish the SOS code from the error flashes.

When I place it back into DFU mode to do the particle flash --usb tinker -same thing happens. This is the result:

Only difference is then it constantly reboots and return back to red flashes restart, one white flash and then reds again. Constant rebooting.
Any ideas?

The suffix error can be ignored, that’s normal.
If you can’t tell what red blink it is, you could post a video showing 10sec before and after the sequence, maybe we can

Here you go - I am attaching the video of the red-flashes.
I hope it helps so I can finally get this figured out.

Thank you!

You did not provide the requested 10sec before and after the red flashes, so we now only see the SOS (… — …) pattern but not the relevant blinks after that!

I think the problem was introduced by the online compression utility I’m using. This site only allows for 10MB file AND only .gif format attachments. How can I effectively convert the original .MP4 file (30MB) without loosing frames? My original video goes through two restart cycles of the Photon

You could post a public dropbox link, or vimo, or youtube, …

Any updates on the solution to this? I’ve managed to get into the same behaviour. It’s SOS followed by 1 red flash. I can’t get it into safe mode, only thing I can do is put it into DFU mode, but no matter whether I hit it with my own known good firmware or tinker, no dice.

This is also happening to me. SOS followed by 1 red flash. Can’t get into safe mode… only DFU mode.