After 1st power up and flash update can only enter DFU mode

Device is a RedBear Duo just out of the box and powered up for the first time.

I tried to use the iOS RedBear Duo app to configure the Duo WiFi credentials. I setup the WiFi to connect to the Duo-xxx SSID. The app found the Duo and offered to update to the latest firmware. I selected that option (perhaps that was not the best thing to do since WiFi had not been setup yet).

The firmware upgrade seemed to go ok and after a while the app came back but never offered the option to configure the WiFi. Reset the Duo to try configuring WiFi again but no SSID being broadcast by Duo so could not connect app.

Now the only mode I can get into in DFU Mode. On power up the RGB flashes Green when the Green if off the little Blue LED on the edge turns on so they alternate. During this time the PC makes a sound like I am plugging and unplugging the USB cable.

I installed the particle CLI but it cannot see the Duo which is probably as expected as the USB never connects to allow the USB drivers to be installed. I then installed the DFU Mode drivers and the beeping sound stopped and device manager shows libusbK USB Devices/Duo DFU Mode. So it seems the boot loader is ok.

If I execute “dfu-util –l” I get the following information. Although the “Cannot open DFU device” has me a little worried I might not be able to flash good firmware into the Duo.

Cannot open DFU device 05ac:8289
Found DFU: [2b04:d058] ver=0200, devnum=12, cfg=1, intf=0, alt=2, name="@Serial Flash /0x00000000/192004Kg,128004Kg,64004Kg,128004Kg", serial=“00000000010C"
Found DFU: [2b04:d058] ver=0200, devnum=12, cfg=1, intf=0, alt=1, name=”@DCT Flash /0x00000000/01016Kg", serial=“00000000010C"
Found DFU: [2b04:d058] ver=0200, devnum=12, cfg=1, intf=0, alt=0, name=”@Internal Flash /0x08000000/01
016Ka,02016Kg,01016Kg,01064Kg,07128Kg", serial=“00000000010C”

So now what? Can I flash good firmware with dfu-util? Where do I find the correct firmware for the Duo and what command(s) do I execute with dfu-util to select the correct area of the Duo and to do the flash?

First time user. Thanks for any help.

Jim

Just tried this command and it worked. So I am more hopeful I can fix the Duo with a fresh flash.
dfu-util -a 0 -s 0x08000000:1024 -U newfile.bin

Have you also posted this in the RedBear forum? That’d be the primary place to do that.

I have no idea (yet) where RedBear has their system binaries, but I’d guess for


Update:
Yup, the guess was correct :wink:
Have a look here
https://github.com/redbear/Duo/tree/master/firmware/system/v0.2.4
And read here
https://github.com/redbear/Duo/blob/master/docs/firmware_deployment_guide.md

Thank you very much. That got my Duo up and running again.

1 Like