Adafruit FeatherWing OLED 128/32, no display

Hi
Searched community and cannot find anything relevant. Using a Xenon and a Adafruit FeatherWing OLED with 1-demo-oled-wing-adafruit.ino library. All looks good with I2C signals and power (i.e. draws 200ua and drops to 5.3ua on reset but no oled’s lighting up. Not even random scatter.
Any ideas or do I assume a faulty device?
Cheers

I use the following libraries on Argon or Xenon:

#include "Adafruit_GFX_RK.h"
#include "Adafruit_SSD1306_RK.h"

Instantiate the object like this
Adafruit_SSD1306 display = Adafruit_SSD1306(128, 32);

Note that with the OLED display you need to call .display() to get anything written to the screen!

void setup()
{
    display.begin(SSD1306_SWITCHCAPVCC, 0x3C); // Address 0x3C for 128x32
    delay(1000);
    display.clearDisplay();
    display.display();
}

Hi
Many thanks for quick reply. I had already tried that along with many libs, including Adafruit Arduino code with an ATmega328.
Still no joy, not even a power up flicker.

Doesn’t look good.

Cheers

Graham

When experiencing issues with I2C devices it’s always advisable to check the I2C connection with an I2C scanner sketch.
e.g. this one
https://go.particle.io/shared_apps/58cda34c77e5d3ec090004fe

Many thanks for that, very useful.

Yup, it found the device at 0x3C

Thanks again.