Abort the setup process

I bought 2 Photons and want them register in the Particle Cloud.
Used the Smartphone App Process and at step 5 “Verifing the Ownership” the setup process aborts.
Now I have 2 Photons green and blue-Blinking.

The step using particle device doctor want help.

Why could not the photons be registered and what is the next step?

The smarthone App informs “setup process failed at claiming your Particle device, if your device LED blinking in blue or green this means that you provided wrong WI-FI credentials - pls try again”.

I know my Wi-Fi credentials and restart my DSL Router. All other Photons work fine.

Try particle serial wifi instead of particle setup

1 Like

Did it - Photon blinking blue, but not connected to the Particle Cloud.
Neither the registration process via smartphone nor via the browser via setup.particle.io runs completely: I can recognize the photon with particle identify, but a WiFi registration at the photon itself is denied.

Just to confirm, the photon is blinking blue (not cyan), and you’ve tried ‘particle serial wifi’? Could you show us the output of that?

1 Like

Yes, sure. Here are my 4 steps:

a.) start point after power via USB

b.) after pressing 3 seconds Setup

c.) command: particle serial wifi - quits with success “Done”

d.) again blue

Does safe mode work?

No, following this instruction no magenta color is available.

1 Photon solved with this steps in DFU-Mode (blinking yellow):

a.) particle keys new
b.) dfu-util -d 2b04:d006 -a 1 -s 34 -D device.der
c.) power it off/on
d.) particle serial wifi (setup your WiFi-Credentials (I did it in manual mode))
e.) particle identify (copy your device ID)
f.) particle device add (Ownership claimed in this step)


I can’t recover my second photon: this device blinks cyan (5 sec) and 1 sec RED.

Do I have a Bad Public Key?

Any help would be nice!

Make sure you’ve updated the CLI, and then give ‘particle doctor’ a shot.

Log from the doc - at the end from the process its blinking white (no wifi on):

! This device is not claimed to your Particle account.
! Resetting keys for a device you do not own may permanently prevent it from connecting to the Particle cloud.
? Skip resetting keys? No
Put the device in DFU mode
Tap RESET/RST while holding MODE/SETUP until the device blinks yellow.
? Select Continue when ready Continue

!!! I was unable to detect any devices in DFU mode…

Your device will blink yellow when in DFU mode.
If your device is not blinking yellow, please:

  1. Press and hold both the RESET/RST and MODE/SETUP buttons simultaneously.

  2. Release only the RESET/RST button while continuing to hold the MODE/SETUP button.

  3. Release the MODE/SETUP button once the device begins to blink yellow.

Make sure your device is in DFU mode (blinking yellow), and is connected to your computer

>> i bring it in DFU mode, but Doc can’t reach this and ends without a second try.

Error - No DFU device found
The Doctor didn’t complete sucesfully. undefined

After I do it manually in DFU mode:
particle update
particle flash --usb tinker (this is the moment cyan and red appears again (I thought WiFi-credentials were cleaned by the doctor)
particle serial wifi

? Should I scan for nearby Wi-Fi networks? No
Attempting to configure Wi-Fi on /dev/cu.usbmodem1421
! Something went wrong: Serial port closed early

Status: fast cyan blinking with one red spot after 5 sec.

I found this solved thread with the same topic (should I give a try?)

Resetting the credentials manually shouldn’t ever be an issue, so you could try that.
What does it do after flashing Tinker? Does safe mode work then?

Yes, I cleaned manually WiFi-credentials by holding >10 sec in listening (blue blinking) mode.

Photon quit this with cyan + red.

Yes, after particle flash --usb tinker again by using DFU (yellow blinking) mode, the

Photon quit this with cyan + red, but I can change to DFU mode again if necessary.

Remark: Sorry if I mix the topics, but in my yesterday’s success with the Photon 1 I have now established that as soon as I get close to my router the photon 1 its WiFi credentials “forget” and again green flashes.
What a phenome.

Prerequisite is a registration at the router connected with the right to do so. All users, who are struggling with green or blue flashing devices, so first recommended to check their own WiFi router again to check that new devices are allowed to login.
I myself use a Fritz box 7390 where the setting is here:

  • WLAN
    ** Sicherheit
    *** set “Alle neuen WLAN-Geräte zulassen” instead of “WLAN-Zugang auf die bekannten WLAN-Geräte beschränken”

I will check whether the red flashing photon can be applied to it.
Thank you very much for your participation and feedback!