Xenon blinking green after breathing cyan


#21

[workaround for always fast flashing green found for me]

I found an old Dlink DIR 505 “All In One Mobile Companion” (with modes as router, hotspot, etc.)
I put it in Router mode between by Linksys WRT1900AC and the argon gateway

and the xenon’s have all been breathing cyan ever since.

If it was just an ip6 thing then I am not sure why just disabling ip6 on my main Linksys WRT1900AC didn’t work.

====EDIT====
I SWITCHED TO A DIFFERENT WORKAROUND
I DELETED MY 3 DNS ENTRIES DOWN TO 2 DNS ENTRIES AND DISABLED IP6 AND MY WRT1900AC IS NOW WORKING WITH THE ARGON/XENON MESH)

SO THAT MAY BE AN OPTION FOR THOSE HAVING THE ARGON/XENON ROUTER ALLERGY AND WITHOUT AN ALTERNATE ROUTER
===END EDIT===


What does xenon fast flashing green mean?
#22

@jtmoderate876, another member mentioned that disabling IPv6 doesn’t always actually disable on some routers!


#23

How does a Xenon flashing green have anything to do with the router? I don’t understand how that can be so, when a Xenon doesn’t have WiFi. If the Argon is connected and breathing cyan, and the Xenon is communicating with it through mesh, then where does the router come into it?

I’m having the same problem as a lot of other people. The setup of an Argon and a Xenon in a mesh network went smoothly (iPhone and Apple Airport Time Capsule). Within a minute or two, the Xenon started rapid flashing green, and only reverts to breathing cyan briefly if I reset the Argon. I can’t even test the mesh connection because the Xenon won’t stay connected long enough to download new code.


#24

Hello,

Thanks all for your comments. On my side I cannot disable ipv6 in my current router’s firmware. I could of course buy a second one which I would use only as AP and switch off ipv6 but why?
At the end the cause is not really known so I decided to do some scenario testing as following:

A brand new Argon and Xenon reinstalled with the hybrid-0.8.0-rc.25 , the Argon already set with the wifi credentials, the xenon already paired with the Argon (all done through the Particle iOS app)

  • Start the Argon first, wait until it breath cyan (take only 2-3s max), then turn on the Xenon: it takes a couple of blinking green, then blinking cyan and then breathing cyan. This remains ok for 30s to 60s then it turned to the infinite loop of blinking green and every mn or so red blinking and restart … then again blinking green fast, etc…

Start the Argon and the Xenon at the exact same time: Argon will breathes cyan quickly, then couple of seconds later the Xenon also breathes cyan. I tested for 5mn, and the Xenon did not disconnect.

Start the Xenon first, then the Argon. The Xenon blinks green for ever until the Argon is switched on, then short after the Argon it breathes cyan too.

In any scenario, when the Xenon was in aBlinking Green stated, just pressing the reset button on the Argon returned everything to normal for the paired Xenon (after Argon get cloud connected, the Xenon will do too)

But after a short period 30 to 60s, the Xenon will then enter a weird mode, going from cloud connected to blinking red, then restarting and then the green blinking mode for ever …

…until the Argon is reset, then when the Argon gets cloud connected, then the Xenon enters a new kind of 2-3 cycles, going from blinking rapidly cyan to blinking white/orange(red?) … this for 2 or 3 cycles, then blinking red, then restart and then connecting to cloud again (breathing cyan)

Finally his seems to be somehow “stable” … at least for 3 minutes, then blinking red, restart, and connecting to cloud, then same thing for a couple of time every 2-3 minutes… but after a few cycles it will loose it again and get back to blinking green (fast) until I reset the Argon …

Ok, long text, lots of cases. I hope this helps Particle to figure out what is going on. If you need more info, more test (could even make videos if that helps), just let me know.

But I need this to work! My setup with Argon plus multiple Xenon was suppose to be the foundation for my new eating system in house … and here in winter with down to -20 deg Celcius, it needs to work and be reliable!

Thanks for your effort on fixing that issue!

Steven


#25

I ran into the Xfinity (Arris) issue pretty early on. I wasted hours and hours trying to get either an Argon or a Xenon/ethershield working as a gateway before one of the firmware developers almost accidentally discovered what was happening… The interesting thing is, the gateway device would connect fine and breathe cyan, but no endpoint Xenons ever got beyond blinking green. I.e. they never went to breathing cyan. Putting a DD-WRT/Linksys router behind the Arris modem, configured to serve up DHCP (note that at the time I thought it was a DNS issue, but apparently it’s when DHCP serves up IPV6 addresses that things go wonky), allowed the endpoints to connect.

Anyway, I’ve been able to test rc.26 and it does indeed fix that. There are some other fixes/features/enhancements in there but I’m not sure if I’m allowed to share them. It should be out in the next few days, but testing only started yesterday…


#26

@Ric It is inexplicable (until someone figures out why) but changing WIFI ROUTER can address the fast flashing green MESH problem.

I’m not so sure the fast flashing green problem has anything to to do with IP6.

What I am sure of is that the mesh network is suseptible to something about the router used by it’s gateway.

If you have another router or 5, try them in between your gateway and your “real” router.

That fixed this for me here::


#27

Perhaps related but I have a 1 boron and 1 xenon setup, it was all good and after disconnect and putting usb power back on, they both went into flashing green problem. On the boron though if I connect a LiPo while powering it on, it goes back to breathing cyan normally. I wonder if there is not enough power being drawn for the initial connection through my USB?


#28

The Boron 2G/3G should have a LiPo battery connected when used–as it will draw more than enough power than what USB can provide.

With that said, we have found the Boron LTE actually should not require this given its reduced power consumption.


#29

I don’t have any other routers to try, and I’m not about to go out and buy one because Particle didn’t get this right. Hopefully, they’ll get it fixed soon, because the mesh is unusable in its current state (for a lot of us any way).


#30

Try the rc26 firmware that’s avaliable now.


#31

I see that version on the Web IDE, but refreshing my code doesn’t seem to be updating it to rc-26; it still says it’s on rc-25. I never know wether to believe what I see on the Web IDE, since it says both my new devices are online when they are not. When I try in with the CLI, it says there are no updates available for that device. I also don’t see that release on the mesh firmware release GitHub page. Is there any other way to tell what firmware version is on the device?


#32

Interestingly, I’ve been able to update some of my devices thru flashing new firmware thru the web IDE using the default - rc.26

3 out of 4 xenons are now on rc.26. I can’t seem to figure out why sometimes they update and other times they do not update the system firmware.

I’ve been able to update a gateway Xenon, node Xenon, and a node Xenon connected thru an Argon gateway. Haven’t been able to get the new firmware on the Argon or Boron.


#33

I have not been able to try the new rc26 firmware yet.

Sounds like @jimbol has gotten it working on some devices. Any improvements?


#34

Is the Serial connection working for you? @jimbol, for you? I don’t see a serial port on my Mac from either of my devices. My Photons work fine, but I don’t get anything with either my Argon or Xenon.


#35

rc.26 Looks OK so far, but nothing conclusive. As you might have read before, my networks were performing much better than yours sounded to be to begin with. I’ll be curious to see how they work overnight and thru tomorrow. I won’t be able to get back to them till tomorrow evening.


#36

I haven’t tried the serial except to try to flash by USB, but I wasn’t successful.


#37

The Web IDE is pretty flaky right now. If I look for the version details on my devices, it says default is 0.8.0 rc.26, but if I then hit the refresh icon, it reverts back to default 0.8.0 rc.25.

Hoping for some progress tomorrow!

J


#38

Flaky is putting it mildly. I flashed my mesh heartbeat code to both devices multiple times now – it appears that it works, I get flashing and the IDE says it was successful, but now somehow Tinker is back on both devices. What?!? I confirmed that from the iOS Particle app, and I can control D7 from the Tinker app now. I did have that heartbeat code on the devices before I tried to get it to update to rc-26.


#39

From what I saw, if you select RC.25 instead of default, it would flash the selected code and run it. If I selected default, it would revert to tinker.


#40

Just tried to flash the RC26 to Argon and 5 Xenons but it’s still showing RC25 and all devices ar back to flashing green again. Not sure what to think :grinning: