Wifi keeps disconnecting, then reconnecting (Photon 2)

My WiFi keeps disconnecting (then trying to reconnect). I've tried two difference SSID's on our LAN (2.4Ghz and 5GHz) and I get the same result. I am on my home network. I normally use a wired connection so I haven't taken the time to connect wirelessly and see if it's a local network issue or not. But in case it isn't a local network issue and it's possibly related to either my device (and/or the code I working with) what are some things I can do to troubleshoot it? I have the serial monitor on so I copied and pasted the output below. I've went to device set up twice and "re-flashed" and reconnecting wirelessly but the issue still persists. At the moment, i'ts disconnected and re-connecting for at least 15+ minutes.

The output of "DNS server list changed" could possibly be a sign of my local network issue as the current SSID I am connected to use the ISP's DNS servers (which I normally stay away from). But the previous SSID did use a different DNS than ISP and still had issues so...

Any suggestions or advice on how to troubleshoot this further?

0000001580 [hal] INFO: WiFi on
0000001818 [net.lwip_rltk] INFO: promisc_deinit TODO
0000001823 [hal] INFO: WiFi off
0000199314 [hal] INFO: WiFi is already on
0000230336 [net.ifapi] TRACE: Netif wl3 ipv4 configuration changed
0000230344 [system.nm] INFO: State changed: IP_CONFIGURED -> IFACE_LINK_UP
0000230350 [hal] INFO: DNS server list changed
0000230355 [hal] INFO: DNS server list changed
0000230361 [system.nm] INFO: State changed: IFACE_LINK_UP -> IFACE_UP
0000230400 [ncp.rltk.client] INFO: Try to connect to ssid: CatheadBiscuits
0000230403 [net.lwip_rltk] INFO: is_promisc_enabled
0000230404 [net.lwip_rltk] INFO: get_eap_phase
0000240626 [comm.coap] TRACE: Retransmitting CoAP message; ID: 4474; attempt 1 of 3
0000240826 [comm.coap] TRACE: Sending CoAP message
0000240934 [comm.coap] TRACE: CON 0.00  size=4 token= id=4474
0000241084 [system] ERROR: sock_send returned -1 118
0000241217 [comm.dtls] ERROR: mbedtls_ssl_write() failed: -0x4e
0000241598 [system] ERROR: sock_send returned -1 118
0000241725 [comm.dtls] ERROR: mbedtls_ssl_read() failed: -0x4e
0000241868 [comm.protocol] ERROR: Event loop error 34
0000241978 [system] WARN: Communication loop error, closing cloud socket
0000242137 [system] INFO: Cloud: disconnecting
0000242238 [system] INFO: Cloud: disconnected
0000268366 [ncp.rltk.client] INFO: disconnected

Hey -- I'd like our team to take a look, but we're working into the holiday break. I'd love someone from @Support to keep an eye on this thread for next week.


...looks like it was something with the library (or more like how I was (mis-)using it) that triggered this behavior.

After a period of several hours stable I decided to try to flash the same code again and same thing happened...so my code was the issue here.

Hope all have a great holiday! :tada:

1 Like