WiFi.clearCredentials() bricked my Photon

I built an entire serial UI that I access via PuTTY on my Win8 machine. In the serial UI I have the ability to enter new WiFi credentials. I also added the ability to clear WiFi credentials.

I cleared WiFi credentials just to clear out an old WiFi AP I no longer use. I thought I could just re-enter the credentials I wanted via my serial UI. But when my FW did the WiFi.clearCredentials() my serial UI stopped working. Some built-in query (not my FW) appeared on my PuTTY asking me to enter SSID, password, etc. But I made a typo in that. So that didn’t succeed. My FW’s serial UI no longer works. None of my FW’s calls to Serial did anything anymore.

Now I’ve tried various recovery procedures and nothing works. I have it blinking blue. But my phone can’t find it to setup WiFi again. What do I do now?

Would’ve been nice if you actually said what you’ve tried, so we wouldn’t have to tell you once again, but hey…

Hold setup for ~10 seconds to erase all credentials.

Then, try the phone app again. If that doesn’t work, try it over a serial terminal again by connecting the device in listening mode and sending ‘w’ (I think, it’s been a while).
Alternatively, use the CLI ‘particle serial wifi’. That should work as well.
You could also create new firmware containing the ‘setCredentials’ method, but that goes a bit far…

Also, if you would, listening mode is not ‘bricked’.