Why I can't see my Core with DFU-util?

Translation in English here

J’ai voulu me remettre au travail après un long moment sans toucher au Spark Core (trop occupé par d’autres choses) mais au redémarrage du Core, après la séquence de connexion au Wifi, le core est normal pendant 2 seconde puis la led devient magenta fixe.
je vois sur le forum qu’il s’agit d’une mise à jour que le Core n’arrive pas a faire sans connexion USB…?
j’essaye alors d’installer Particle CLI (guidé par ce tuto http://support.particle.io/hc/en-us/articles/203265730-Installing-the-Particle-CLI) puisque je n’ai travaillé jusqu’à là qu’avec l’IDE Build
mais il semble que le DFU-util ne trouve pas mon core…?
j’ai suivi ce tuto Tutorial: Installing DFU-Driver on Windows [24 Feb 2015]

que dois-je faire? qu’ai-je oublié? voila ce que j’ai pour le moment dans ma console (mon Core est bien connecté en mode DFU (led clignotante jaune, et il apparaît avec le bon driver dans les périphériques).

So, this is what Google translate made of your story (translated freely, and summarised heavily):

“Core boots up, works for 2 seconds, then goes to fixed Magenta, and stays that way. According to a forum post, I should update my firmware over USB in DFU mode. I have installed the CLI as documented over here. So far, I’ve only worked with the Web IDE, and it seems that DFU-UTIL cannot find my Core. I then followed this tutorial. The attached image is what I currently have in my console. What do I do, what have I forgotten? My Core is connected in DFU mode (yellow LED flashing, and it appears with the right driver in peripheral)”

Have you got a screenshot of how your device looks in the device manager? Mine looks like this when it’s in DFU mode:

Also, have you tried a factory reset? That might help as well.

I’d highly recommend posting in English in the future, since that’s the language that’s understood by most, if not all, people on the forum here. Posting in French will severely limit the amount of people able to help you. I have thrown it through Google translate to make some sense out of it, since my high school French was a bit too long ago. Imagining that not everyone is going to want to do that, you’re losing a lot of people who are potentially able to help you.


Understood @Moors7, and thank you for your effort, but unfortunately, when a problem is to hard for me I would prefer speak in french to be sure to understand perfectly the answer.
I’m not comfortable with software issue, and understand how all those program interact each other together is difficult for me.
So my device is like you in the device manager

I have made a factory reset then I put the core in DFU mode, and still the same, no device in dfu-util…

Have you installed Zadig and configured the DFU driver (tutorial here)?

yes, exactly like in the tutorial, and this finish with “the driver was installed successfully”

here is my Zadig screenshot

When a question is hard for me, I’d like it to be in a language I understand :wink: I think the majority of the people on the forums here don’t speak French. By posting your questions in French, the amount of people that can help you dramatically drops. It’s up to you, but I’d prefer English.

Have you tried a factory reset? Also, trying a different USB cable and/or a different port may help. Reinstalling the drivers might help as well. Just be sure you first remove them before reattempting. In case of a Windows computer, just rebooting can do wonders as well :wink:

1 Like

Great step! I’ve try a different USB port and this is better now! thank you Moors7
I have now flashed with new factory firmware, and my core work again!

Can you tell me if this new updated factory firmware will be kept in case of new factory reset?

1 Like