Webhooks not firing with Electron

Strangely, this is a recent phenomenon…

I use a “pushover” webhook that I use for many devices to send me notifications. I noticed today that Pushover publishes from my Electron are not getting to pushover…

take a look, there are no “follow-up” responses whan Electron publishes:

I don’t get the hook-sent/pushover event.

Anyone have a clue as to what’s happening?

Particle.publish("pushover", publishString, 60, PRIVATE);


I wonder if that’s deliberate as lots of data will be consumed when the electron is sent the hook-response

@dave ?

Is that a recent change? This worked only a week prior?

If it worked before then i’m not so sure. Let’s wait for the folks to be up!

Good Morning!

I’ve heard some reports lately that some long-running hooks might be occasionally jamming up. I’m looking into the best way to fix this.

edit: Re-reading this thread. So a “hook-sent” message means the webhook got your event, and reached out to the server, but it won’t publish a response if it didn’t hear anything back. So it’s possible that service was having an issue at that moment.


The screenshot shows 2 events(or at least one since the last is the latest event) from an Electron that does not trigger the hook-sent event.


If events from the Electron are “never” triggering the hook, it could be a result of different firmware that had the wrong privacy setting (public vs. private) depending on how the hook was configured?

The electron should use the same internal event system as the other devices, so there shouldn’t be a special reason why an event from an electron wouldn’t trigger the hook as far as I know.


The privacy setting is identical in the Photon publish as the Electron, as shown in the snippet above.

As pointed out in the screenshot and by @MORA , all things are not equal, and this worked several days ago!

Hi @BulldogLowell,

Hmm. Well that’s pretty weird! Just to clarify, you’re still seeing this behavior yes? You can trigger the hook from a photon but not from an electron?


Yes and yes.

I agree it is pretty weird.


particle publish pushover "Some Data" --private

works OK too.

My code:

const int triggerPin = D1;

FuelGauge fuel;

char publishString[128] = "";

void setup()
  pinMode(triggerPin,INPUT);  // External Pulldown Resistor attached
  int startupTime = millis();
  while(millis() - startupTime < 2000UL)  // allowing time to take digitalRead()
  sprintf(publishString, "Power %s, Fuel:%.1f%%", (digitalRead(triggerPin) == HIGH) ? "Restored" : "NOT Detected", fuel.getSoC() );
  Particle.publish("pushover", publishString, 60, PRIVATE);

void loop()
  System.sleep(triggerPin, CHANGE);

wild, wacky stuff

1 Like

Could this be a in connection with a issue I had opened with 0.4.6 (or 0.4.7) about inconsistency in behaviour between Core and Photon over different versions?
This was solved for the Photon with 0.4.9 but Electron has 0.4.8.

So, as it happens, My Electron wasn’t accepting a flash. It appeard to do so, but it didn’t.

I did an update and voilá, it works now.