Web IDE is not working


#1

My gizmo is not working. This is not unexpected. Got out my scope to probe pins (a Diligent Analog Discovery 2). Modded a program to twiddle one of the lines so I could probe it and…

The IDE has stopped working.

We are not amused and autistic programmers can be grumpy.


#2

On the positive side. with more memory, my laptop is working VERY nicely.


#3

That is a very vague description from which we can deduce virtually no usable data.
-what exactly isn’t working? (Compiler errors, unresponsive, not loading, you name it…?)
-what browser are you using, preferably with a version?
-where are you located, so local issues can be rules out.
-have you tried closing the browser tab, browser, restart, another browser?
-have you checked the browser debug console for potential errors?
-what device?
-what deviceOS?
-etc…

On this forum there’s no such thing as too much information, but almost always too little of it. Please be as generous as you can with the information you provide us so we have something to work with, don’t have to ask things that seem obvious and would frustrate you, or waste everyone’s time by receiving suggestions to do things you’ve already tried.


#4

Don’t think any of your questions could account for error 404 when doing a make, flash or trying to go to the console.

Browser: Firefox
Location: Broken Arrow Oklahoma USA
Rebooted the whole stinking computer. Tried again the next day.
Device: Electron
OS: I don’t know, the https://console.particle.io/logs says:

Bummer! That’s not the page you’re looking for
But as long as you’re here - would you rather fight a shark with bear arms or a bear with sharks for arms?


#5

Same in Chrome.

Should I try Edge?


#6

Had you told us that immediately, I wouldn’t have had to ask so many question that might not have anything to do with your issue. For one, the Web IDE and Console are separate identities, and should operate independently. Both are working for me here in the Netherlands/Germany.

That one might actually give some more information, so if you wouldn’t mind checking that, that could help.

Any chance your router might be giving you headaches, or your ISP even? If possible, could you try checking it using a mobile devices over the cellular network? Either a hotspot to your computer, or checking on the device itself should be fine for this.

Seeing as you’re the only one so far to report this, I suspect it’s a local issue (possibly local to your network), so testing on a different network should help rule this out.


#7

Both are working from Pittsburgh, PA, USA as well. Windows 7 Pro, Chrome, Consolidated Communications (ISP).


#8

Did you mention that error in your opening post? :wink:

That would rather be https://console.particle.io/events, but this wouldn’t tell you anything about the individual device.
In order to learn about the device you’d go to https://console.particle.io/devices


#9

Electron is breathing cyan. Blue led is flashing, that’s my indication that the program is running. Screen is white, but program is supposed to make it red. Obviously, I have something goofed up. Let’s see what…

I modify my program a bit to twiddle one of the lines so I can see if it’s where I think it should be.

I go to verify my modified app:

Hmm. Error 404 in trying to verify?

Let’s see what the console says.


#10

As I said above,

/logs was the old path but now it’s /events.

Also try to log out of Web IDE and back in and maybe even clear the Web IDE cache and reset the access token

It may also be that your firewall is blocking some port that is required for the build - but the browser console (as already mentioned by @Moors7) may provide some more clues.

Having to repeat our proposals/advice in order to help isn’t that amusing either.


#11

Logged out. Cleared browsing data, everything I could find to clear. Rebooted. “Windows updating…” Took Christmas lights down. Logged in:

Logged in using James’ Macintosh and flashed my silly electron.

Cleared cashes and whatnot again. Rebooted.

Now it lets me log in and flash my electron (sounds a little kinky).

“Hey, you windows machine, how do you spell ‘linux’?” fp


#12

Oh, yes. When I click the console button, it foes to console.particle.io/logs that redirects quickly to events, assuming it’s working…

(This only happens because I’m working in a new IDE and new hardware. If I was old hat at particle, it wouldn’t have happened.)


#13

If it works on a different system, on the same network, there’s most likely something wrong with your original system. There might be plugins, firewalls and whatnot blocking your connection. As mentioned a couple times before, the console debug output from your browser could help shed light on this.


#14

Worked when it had 4GB ram, not when it has 16GB. Worked for a while yesterday, but is wonky again today. Running Microsoft’s memory diagnostic while commandeering Jame’s Mac.

I actually flashed it using my phone. That would be a hard way to program.