Web IDE drops changes, reverts to old code

Yesterday I made several hours worth of changes to one of my programs, did a Save and recompiled. Today when I went to edit it in the web IDE, all those changes were gone. My program was back in its previous state. I made some more changes and the same thing happened. The changes appear to take based on the resulting execution but if I switch to another program and then come back, all my changes are lost. I tried refreshing the page, didn’t help.

This is needless to say extremely frustrating. ???

Not saying that isn’t happening, but could it be that you are using multiple machines to work on - or multiple browser tabs/sessions with Web IDE open for that matter?

I had that happen in the past, where I carried on working on a machine/session which still had a old version cached resulting in overwriting the chanes made and saved on a different machine/session.

Thanks for the speedy reply. I’m only working on one machine but I do have two browser windows open. One has the web IDE, the other has this window. But I’ve been doing that for a long time. This problem only popped up today. It’s happening with other programs too. Switch to a different program, come back, find all your changes gone.

Actually I’m thinking of jettisoning the web IDE entirely. I’ve never really liked the UI (purely personal opinion). I’m going to try installing Particle Workbench and see what that gives.

1 Like

you will not regret, VS Code is awesome!

Like @ScruffR mentioned, what you describe only happened to me when I was using more than one tab/browser at the same time.
What browser are you using, maybe that would be an issue? I hope is not internet explorer :slight_smile:

1 Like

Good heavens no, I’ve never used Internet Exploder. I’m using Firefox Meanwhile I’ve got the Particle Workbench installed but I’m still trying to figure it out. The learning curve is a bit on the steep side.

I’ve got my program open in the editor but I can’t figure out how to connect it to all the community libraries it needs. And the Particle documentation doesn’t match the UI I’m seeing.

can you please post a screenshot of the UI you are seeing, please?

Shift+Ctrl+P
image

You could manually add the dependency entries in project.properties but a proper install is cleaner - especially for offline building.

Hmm, OK so I do Shift-ctl-P, select Install library and it says “Please open your project.properties file”. So I open the file, do Install library again and it still says “Please open your project.properties file”.

that’s the regular UI with workbench, however:

  • How did you open the project?
  • Was it ever saved? I wonder why it still says UNTITLED (WORKSPACE)

mine shows the project name (in this case MESHGARAGE):

Could it be that you need to save your project before adding a lib?

1 Like

I forget what I did to get my source code in the editor. But I never did a Save so I did that. Now it has the name of my project but it still says to open the project.properties file, even though it’s already open.

hi :wave:

if you haven’t already seen them, we have a bunch of docs and walk-thru videos:

https://docs.particle.io/workbench/

in particular, you might want to check out:

Getting Started with Particle Workbench:

Building Firmware Locally with Particle Workbench:

just guessing from your screenshot but it looks like you need to run the Particle: Create Project command and then pull over your source code and paste it into the ./src/<your-project-name>.ino file. at the least, you can run that command and compare the file layout between your two projects - you’ll want to match the one created via the Create Project command.

hope it helps :+1:

2 Likes

@Michele Did we get you there? Are you still having issues?
Cheers
Gustavo.

1 Like

Hi Gustavo, sorry for the delay getting back to you. I had to deal with Real Life ™ for a bit. Anyway, I watched the video and created a new project. Now when I do Particle Install library it does ask me for a library name but it always says “Library (library name) not found.” I’m just typing in the library names from the include statements in my code.

One question - can I do local compiling and OTA flashing with the Workbench? My weather station Photon is way out in the back yard and it wouldn’t be very convenient to bring it inside to connect via USB every time I want to modify the code. The impression I got from the video is that it’s either web compile + OTA flash or local compile + USB flash.

Now when I do Particle Install library it does ask me for a library name but it always says “Library (library name) not found.” I’m just typing in the library names from the include statements in my code.

as you’ve found, those don’t always correspond to the name the author published the library under. try the Particle: Find Library command and see if that gets you closer :+1:

also:

can I do local compiling and OTA flashing with the Workbench?

yep! you’d run the Particle: Compile application (local) task and then use the Particle CLI (run Particle: Launch CLI from within Workbench) to flash the resulting .bin - particle cloud flash <device> <path-to-your-app.bin> :+1:

1 Like

no worries on the delay, Real Life always takes priority. I did not want you to feel overwhelmed and give up.
Cheers and keep asking questions and keep trying until you reach your goal.
Gustavo.

1 Like

Ah, I see what happened. As it happens, the first two libraries I tried to install, “vl53l1_register_map” and “Sparkfun_VL53L1X_Arduino_Library” are in fact not community libraries. They are included directly in my web IDE project. It’s been so long since I added them I completely forgot about it. I tried the next two libraries and they included fine.

So the next question is how do I include these private libraries from my web IDE? (I actually have seven of these, cpp and h files).

I think you create new files on VS code next to the ino file of your project and that will be all.

1 Like

You can download the project from Web IDE this way
image

And then place the respective files into the src folder in your Workbench project.

1 Like

Ah! I never even noticed that little thingie. Thanks - that was much easier than opening each file in turn and then copy/pasting it into an editor to save a local copy.

But now I’m still getting a hard time from the DallasTemperature library. The problem is that compiling this code throws a ton of warnings from the libraries so the error messages get buried. Is there some way to suppress warnings ( like “gcc -w”)?