VSC intellisense problem since release 1.53.0

Since accepting the upgrade to 1.53.0 I have been seeing some very annoying issues with intellisense that are really denting my productivity - solution is to shutdown and restart/reload VSC.

Installed details are: Version: 1.53.0
Commit: 8490d3dde47c57ba65ec40dd192d014fd2113496
Date: 2021-02-03T16:01:04.046Z (3 days ago)
Electron: 11.2.1
Chrome: 87.0.4280.141
Node.js: 12.18.3
V8: 8.7.220.31-electron.0
OS: Darwin x64 20.3.0

Anyone else having these problems? I am running it on macOS Big Sur.

thanks for raising the flag. have you tried the troubleshooting steps over here?

if we have that debug info, we can better investigate and if need be escalate to GitHub - microsoft/vscode-cpptools: Official repository for the Microsoft C/C++ extension for VS Code. :+1:

Thanks for the reply - I was just trying to judge whether anyone else was having the same problems or just me. The whole folding and unfolding thing just stops working and chunks of source code disappear.

The whole folding and unfolding thing just stops working and chunks of source code disappear.

hm. that’s definitely odd. it sounds like a core issue w/ the underlying extension (GitHub - microsoft/vscode-cpptools: Official repository for the Microsoft C/C++ extension for VS Code.) as our bits are really only concerned with exposing the api specs. iow, if you hover over a symbol or right-click → peek definition and get accurate api + type info, then WB is doing what it should.

First the fold/unfold chevrons disappear then chunks of code. Often the peek definition is not working and auto-fill as well - I have re-installed the C/C++ extension.

very strange. you’d be surprised how often extensions will conflict with each other and generally cause havoc. if you haven’t already, definitely try disabling (even uninstalling) any non-workbench related extensions and see if that helps.

Could this have anything to do with what I am seeing? It pops up in output as a C/C++ configuration warning.

For C++ source files, IntelliSenseMode was changed from "macos-gcc-x64" to "macos-gcc-arm" based on compiler args and querying compilerPath: "/Users/wjsteen/.particle/toolchains/gcc-arm/5.3.1/bin/arm-none-eabi-gcc"

best option is to run through the troubleshooting steps here:

:+1:

1 Like

I think I got this sorted out - essentially I uninstalled all the Extensions including Workbench and re-installed everything and re-launched VSC. Your troubleshooting steps probably need to be updated to reflect exactly which extensions and versions are known to work/aligned to each other.

1 Like

glad you’re back in good working order :+1:

Your troubleshooting steps probably need to be updated to reflect exactly which extensions and versions are known to work/aligned to each other

this step helps us do that:

  1. run the Particle: Audit Environment command and share the non-sensitive parts

…did you happen to keep that info around?

essentially I uninstalled all the Extensions including Workbench and re-installed everything and re-launched VSC

this rarely is the right solution. when it helps, it’s nearly always masking some smaller step that is actually responsible for fixing things. this is why the troubleshooting steps i linked you to do not include reinstalling.

the key bit is really:

after each step, verify that you are still seeing inaccurate issues in the “Problems” tab within VSCode.

…as this helps identify where things are going weird.

-matt

Will

(Attachment Workbench environment audit report.rtf is missing)