Using Boron completely offline

So… I took a NorAm Boron BRN402 with me to Europe. :man_facepalming: I didn’t activate it before I left.
I just want to be able to do local dev / bluetooth features with it. I don’t need cellular at all
It’s sitting here blinking green at me. I’ve tried the neopo flash-all command, which does work to put the device in DFU and flash it, but it doesn’t seem to run the code. Is there any way to do this?

System mode has been set to manual

particle usb list outputs:
< no name > [e00fce68a38a16f9e797cb5c] (Boron)

Thanks!

1 Like

You can put the device in DFU Mode and flash any code that uses SYSTEM_MODE(MANUAL). This way the device will not try to connect to the cloud at all.

If it still tries to connect to the cloud nonetheless, it could be that the code you flashed was targeted at a device OS version that would require an update and that may be the reason why the device wants to connect.
You can also update the device OS via DFU Mode particle update -v
This should get your device to the latest official release.
If you want to use a pre-release version, you need to download the binaries and flash them via particle flash --usb <deviceOSxxx.bin> -v

To get a better idea what the current state of your device is, you can put it in Listening Mode and run particle serial inspect

2 Likes

Using neopo flash-all will flash application and DeviceOS exactly like Workbench does. IIRC neither Workbench or neopo will flash the bootloader however, and I think the boron is trying to download the bootloader from the cloud. (I should add a command to neopo for this.)

In the meantime, I think you can download the appropriate boron bootloader from the releases page and flash it to your boron with DFU.

EDIT:
@tunahammer I’ve pushed an update to neopo to provide a command for easily building and flashing the bootloader for a specified platform and Device OS version. Simply update your neopo installation and the new command will be available.

For example:

neopo bootloader boron 3.1.0

Also, you said you never activated your boron. Is it possible that you need to set the setup flag to done?

1 Like

@nrobinson2000 wow, I didn’t expect such a fast response and custom help with the patch! I have updated to your latest version and it did apply the bootloader!!!

I am so happy to have an auto flasher that is so simple to use now!!! This is great!

thanks for your help. :heart_eyes:

1 Like