USB Power Issues

I have two Particle Borons. I updated and flashed tinker to the devices via the USB. I am having issues powering either device from the USB. I am not powering both at the same time, but rather the two devices indicates it seems to be repeatable. Neither device seems to have power from the USB.

When I plug in the USB to the Boron, the main LED flashes ‘blue’ and the lights flicker for a second, then dark (as if there is not power). I can power the devices by applying 6-7V to VUSB pin and GND. However, the device goes into listening mode and does not connect to LTE. Since it is connected not to the USB and not to LTE, I don’t know how to communicate with the device for further troubleshooting.

I have tried multiple micro-USB cables. I have one USB cable that powers the device to flashing blue, but does not detect the device in command prompt (Windows 10) by running ‘particle usb list’.

Any thoughts on how to recover?

Hi @Jay_Mil perhaps you can out USB Serial troubleshooting: USB Serial Debugging | Tutorials | Particle If this does not work, feel free to log a ticket at support.particle.io .

@Jay_Mil ,

Powering a Boron from USB can present some issues - though less than the Electron days as Boron power usage is much lower. Still, a few things to consider:

  • While you are powering your Boron using USB, do you also have a LiPo battery on the Boron?
  • If so, the combination of current draw from connecting (versus simply flashing) and charging the battery could draw more power than your USB power source can supply. Default max current draw for charging on the Boron is 900mA and a typical 5W USB brick or USB port on a PC can reliably only provide 500mA.
  • Do you have access to a 5V / 10W USB brick such as the one that comes with an iPad? If so, you may want to try it.
  • Finally, there is an amber LED on the Boron for charging (assuming battery installed) if it is flashing slowly (1 Hz) this indicates that the device is not receiving sufficient current to support charging and the PMIC is in an error state. Another clue to look for.

Hope this helps.

2 Likes

Thanks folks. I tried the serial monitoring, but it could not find the device. Likely because the unit is not getting sufficient power.

It does seem like a power issue as the amber light flashes on startup but also goes out. The USB power brick still did not work, however, I hooked up an external power supply and can power on both units. So that leads me to think that the units are both good, but I cannot communicate. One unit powers up to a flashing blue light (listening) and one powers to a flashing white (cellular off).

Not sure where to head from here to recover the devices, thoughts?

@chipmc @particle7888

Hey Jay- Can you DM me the device IDs of your Borons? I’ll take a look at the console to try and figure this out.