Boron found dead and irrecoverable-without-LiPo after 1-month of normal use - what happened?

Tags: #<Tag:0x00007fe21e5135f8>


My V1.3.1-rc1 Boron (B40HAB9139CRJ8X) was faithfully uploading telemetry data until 1pm today.

I have recovered the remote unit to discover the unit is totally broken and will not turn on when plugged into USB. It was found dead with LED off.

When one plugs this dead Boron into regulated 5V USB, the LED will become solid white for less than a second and then totally die - shut off as if it failed to boot or something.

However, with a LiPo connected, it will now magically turn on and connect. This is very frustrating as the Boron was failing to charge the LiPo during deployment, and the battery was 0% when it died at 1pm today (the whole time, Boron has been powered with regulated 5V on the USB pin).


-Boron deployed about a month ago
-+5V to USB pin using L7805 regulator from 6V SLA battery, solar powered
-LiPo has been connected throughout the deployment
-LiPo charge fell gradually until hovering between 2 and 5 percent in the last few days, finally recently to hit zero
-Particle console showed USB charge symbol intermittently, however LiPo never fully charged
-5V to GND inputs had 0.1uf bypass capacitor
-My charge code executed on setup was:
pmic.setInputCurrentLimit(900) ;
-I want to use Particle for my projects, but I need to have reliability. I know it is possible because I have another Boron unit not having this issue (it however has a 12v solar system).

Can someone very knowledgeable about the Boron hardware and power supply/regulator comment on the clear hardware power-related failures I’m experiencing with Boron and what can be done to mitigate them for 100% reliability?

Thank you.

Update: The unit will connect to cloud on USB-power-only when I hold down Mode and Reset to enter safe mode (purple flashing). Currently investigating hypothesis that the setup call to PMIC code above is causing a software-related crash, which would mean this is not a hardware issue. Indeed I did seem one time a few weeks ago to observe legal PMIC calls totally crashing a Boron to a dead-seeming state.

Entire Particle Boron platform currently INOPERABLE due to solar/PMIC/power/battery issues

Usually if it’s a hardware issue, safemode won’t have an effect on connecting to the cloud. This leads me to believe its your firmware. I would reflash tinker to confirm.

PMIC calls now catastrophically crash Boron due to Particle software update

Thanks. I just 1) flashed V1.4.0, seeing it is released, which amounts to flashing a new bare Tinker install, and 2) discovered this thread:1.3.1-rc.1+ change to Boron solar charging (via VUSB) behavior

What do you know, now the Boron starts up and connects to cellular with USB only power without any problem, rather than suddenly crashing/dying on startup.

Amazingly, just like that OP, this yet-another Particle software-related update-related catastrophic failure necessitated a 3-hour drive, and will necessitate another 3-hour drive to my remote site.

Just like that OP, I am charging on Solar and needing reliability.

I know this is correlated to the PMIC charging / V1.3.1 issues because two or so weeks ago I found PMIC calls crashing Boron, and the solution was to remove them.

Recently I remotely flashed the code to this Boron restoring the PMIC calls seeing that the LiPo was failing to charge from USB by default settings.

Why does Particle post software updates that massively affect and destroy this product’s usability and necessitate more and more hours of repair, figuring out, and posting on forums?

How can we understand the hard rules and practice guidlines for USB-in solar charging for V1.4.0?

Thank you for your help.


I agree with @Mjones. I was thinking hardware issue (ESD or surge?) until you stated safe mode connects. Likely a code issue.


@picsil Yes but seems to be a Particle code issue. I just flashed a version not calling any PMIC calls and it still died on startup after 1-sec white LED when powered from USB only. Then I installed V1.4.0 (see above) and it worked.

In other words, the same code that worked before without any issues repeatedly caused the Boron to crash.

I am doing more tests and noticing many similarities to this thread: 1.3.1-rc.1+ change to Boron solar charging (via VUSB) behavior


We posted our replies at about the same time. Yes, with this new information something else is likely going wrong. I query the PMIC in my code frequently and have not noticed any issues up to 1.3.1. I am working on a version to support 1.4.0 but haven’t tried it yet due to some other bugs in my code.


from my perspective there could be an alternate probable scenario that goes like the boron will not cut on via usb power alone because there may not be enough current which is no longer the issue when a battery is also connected. then it’s possible that since you are solar charging there may have not been enough sun intensity for a period of time creating a low charge followed by a mains outage which then resulted in the boron slowing running out of power til battery dead and this slow bleed out of battery might caused a data corruption in the boron much like what has happened to the electron. you point out that you flashed the newer firmware and then it worked. so perhaps the act of flashing corrected the corruption issue, that is if it exists. point is it might not be “this yet-another Particle software-related update-related catastrophic failure”. it might have been an unfortunate consequence of a series of events that left the boron in that state.