Updating from DeviceOS 1.4.4 to 1.5.0-rc.2 -> Broken SPI Functionality

Running an existing production project on P1s on 1.4.4 just fine I decided to test stability of 1.5.0-rc.2.

After updating and seeing by device breathing cyan I noticed that my SPI ePaper display wasn’t responding at all. After opening a serial monitor and resetting the device several times it appeared that the device was getting stuck at the point where it initializes the display. Commenting out that part I discovered the same issue when the device tried to initialize my SD card (another SPI device).

After again commenting out the SD Card code my device finally started responding as expected.

For troubleshooting reference I’m using SDfat and older GxEPD2_PP ePaper library.

Tried to do a Particle Serial Inspect but I got the following error Serial err: Error: Opening COM30: Access denied, not sure if that’s relevant at all.

@TrikkStar same problem as mine reported here:

and on a related note:

Let us all know if you find a solution!

1 Like

@TrikkStar please update to the just released DeviceOS 1.5.0 and report back. My guess is that it fixes your issue because it fixed my similar issue.

If so, don’t forget to mark this post as solved!

Yep. Running 1.5.0 everything is functioning as normal.