Try to run "particle token list" since web IDE now hides them and get an error

Can’t seem to find anything on this error while searching. And no CLUE why they would REMOVE the token from view on the Web IDE
Output from my console.

PS C:\Users\Steve> particle token list
Checking with the cloud…
? Using account xxxx@xxxx.com
Please enter your password: [hidden]
! Error in particle-cli:
! processNextTick is not a function
! See C:\Users\Steve\AppData\Local\particle\error.log for more info.
PS C:\Users\Steve>

And the error log
2020/05/20 22:28:08 Time since last update 30m18.165573s, update in block
2020/05/21 05:28:14 TypeError: processNextTick is not a function
at emitReadable (C:\Users\Steve\AppData\Local\particle\node_modules\particle-cli\node_modules\request\node_modules\readable-stream\lib_stream_readable.js:419:21)
at onEofChunk (C:\Users\Steve\AppData\Local\particle\node_modules\particle-cli\node_modules\request\node_modules\readable-stream\lib_stream_readable.js:407:3)
at readableAddChunk (C:\Users\Steve\AppData\Local\particle\node_modules\particle-cli\node_modules\request\node_modules\readable-stream\lib_stream_readable.js:176:5)
at BufferList.Readable.push (C:\Users\Steve\AppData\Local\particle\node_modules\particle-cli\node_modules\request\node_modules\readable-stream\lib_stream_readable.js:157:10)
at BufferList.destroy (C:\Users\Steve\AppData\Local\particle\node_modules\particle-cli\node_modules\request\node_modules\bl\bl.js:211:8)
at Request. (C:\Users\Steve\AppData\Local\particle\node_modules\particle-cli\node_modules\request\request.js:1027:14)
at Request.emit (events.js:311:20)
at IncomingMessage. (C:\Users\Steve\AppData\Local\particle\node_modules\particle-cli\node_modules\request\request.js:969:12)
at IncomingMessage.emit (events.js:323:22)
at endReadableNT (_stream_readable.js:1204:12)
2020/05/20 22:28:14 Time since last update 30m24.1247952s, update in background

Works for me (tested with CLI v2.6.0, node v10.15.1 and npm 6.4.1)

Hi,

maybe you can try updating the cli to the latest version?
This is what I have (and it seems that I need to update it):

$ particle --version
particle-cli v2.5.0

! A newer version (2.6.0) of particle-cli is available.
! Upgrade now by running: particle update-cli

2.5.0

Thanks!

error
Nope looks like it’s current.
I did a full reinstall of everything I could find :frowning:

Maybe @shawn_particle can help here.
Could it be Shawn that you were doing some Particle CLI work? Thanks

There was no recent CLI update released.

Try reinstalling CLI on Linux/Windows

Thanks for responding.
That was one of the first things I did before making this post :frowning:

Why were the API keys removed from the Web GUI?!?!?
Seems like a major issue if people can not access their keys.
Still no change here. Still broken.

At this point I would invite you to open a ticket with Particle support.
Gustavo.