Tracker One - Unable to find CMSIS-DAP device

I’m trying to debug a Tracker One to be able to step through the code within Workbench/VS Code.
From the Particle Getting Started tab, I’m selecting FLASH/Launch debugger.
The device appears to flash successfully - it produces the following output:

Opening DFU capable USB device…
ID 2b04:d01a
Run-time device DFU version 011a
Claiming USB DFU Interface…
Setting Alternate Setting #0
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "Internal Flash "
Downloading to address = 0x00030000, size = 107388
Download [=========================] 100% 107388 bytes
Download done.
File downloaded successfully
Transitioning to dfuMANIFEST state

Following that, a message appears indicating ‘Failed to launch OpenOCD GDB Server’

It then directs me to the Adapter Output window which displays the following:

Info : auto-selecting first available session transport “swd”. To override use 'transport select '.
Info : Listening on port 6666 for tcl connections
Info : Listening on port 4444 for telnet connections
Error: unable to find CMSIS-DAP device

Do I need to make any changes to my machine settings or the launch.json file?

In order to use the source-level debugger (SWD/JTAG) you need to connect the Particle Debugger to the Tracker using the 10-pin SWD ribbon cable. This is not recommended because:

  • You need to open the Tracker One, which will void the warranty.
  • The JTAG connector is not soldered on the board. You’d need to obtain the connector and solder it to the board. It’s a SMD connector.

There is no way to use SWD over the M8 or USB. For initial development the Tracker SoM evaluation board is recommended because it does have access to the JTAG debugging connector and it’s populated on the board.

Thanks for the quick response and saving me time from digging into this further.
I’ll take a look at the Particle SoM Eval Kit and the Particle Debugger then.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.