Toolchain for Windows Installer

I just tried updating the firmware to the development branch but I got the below: Did the new firmware update on the P1?

I went to the main and ran: make PLATFORM=P1 clean all program-dfu

© 2011-2012 Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

No valid DFU suffix signature
New DFU suffix added.
Serial device PARTICLE_SERIAL_DEV : not available
Flashing using dfu:
dfu-util -d 0x2B04:0xD008 -a 0 -s 0x80A0000:leave -D …/…/…/build/target/user-
part/platform-8-m/user-part.dfu
dfu-util 0.7

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Filter on vendor = 0x2b04 product = 0xd008
Opening DFU capable USB device… ID 2b04:d008
Run-time device DFU version 011a
Found DFU: [2b04:d008] devnum=0, cfg=1, intf=0, alt=0, name="@Internal Flash /
0x08000000/03016Ka,01016Kg,01064Kg,07128Kg"
Claiming USB DFU Interface…
Setting Alternate Setting #0
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
Dfu suffix version 100
DfuSe interface name: "Internal Flash "
Downloading to address = 0x080a0000, size = 4564

File downloaded successfully
Error during download get_status
Error during download get_status
make[1]: Leaving directory /c/Users/Main/firmware/modules/photon/user-part' make: Nothing to be done forprogram-dfu’.

C:\Users\Main\firmware\main>

To me that actually looks right. Did the code seem to get updated on the module? Per the firmware github page:

As of 12/4/13, you will likely see Error during download get_status as the last line from the dfu-util command. You can ignore this message for now. We're not sure what this error is all about.

ive been trying to update the system firmware for the P1 using the below and I get the below errors. I’ve already tried updating the PATH as you stated above. Any ideas?

put the Photon in DFU mode
cd modules
make PLATFORM=P1 clean all program-dfu

@mumblepins, just tried making the newest branch called latest and i got the below error:. Whats the best way to updated the ARM gcc version to 4.9.3?

Please pull the latest code. The build system now accepts any compiler version that is at least the minimum required.

EDIT: But please also read the message. :slight_smile: It’s saying it needs version 4.9.3 but you have only 4.8.4 installed.

The pervious error above: dfu-suffix command not found. So you should install dfu suffix also, in addition to dfu-util.

1 Like

Updated release, now pulls down 2015q2, and changes the path adding method.

@wesner0019, it sounds like you have a lot of older versions and such cluttering up your build environment. I might suggest a thorough cleaning up of installations and the path, and maybe some reinstalls. Alternatively, a virtual machine can always be your friend :smile:.

2 Likes

@Bspranger, I think the reason you used Ubuntu is that development is way easier to set up. Here’s a one liner to install the necessary stuff (tested on 14.04, raw install).

sudo add-apt-repository -y ppa:terry.guo/gcc-arm-embedded && sudo apt-get update && sudo apt-get -y install gcc-arm-none-eabi git

You can then clone and build for the Photon with:

git clone https://github.com/spark/firmware && cd firmware && git checkout latest && cd main && make clean all PLATFORM=photon && cd ../build/target/user-part/platform-6-m

Here is a gist with an install script.

1 Like

@mumblepins thanks! I will try this once I get released from the hospital… ;-(

@Bspranger take care :smile:

1 Like

@mumblepins
Nice installer! But it seams that I have some problem :frowning:
Everything seems to get installed and no error occurs, but the folders Make and MinGW are totally empty after the installation is completed…

Any ideas?

Why yes I do have ideas :smile: It’s because Sourceforge sucks, and the installer can’t download them :frowning: This tweet is from 10 hours ago with no update since then, so remember this the next time the Particle cloud has an outage, at least we get updates on it with slightly higher frequency.

#SourceForge site is read-only, developer services disabled due to storage infra fault. Service restoral work in-progress, ETA to follow

— SF.net Operations (@sfnet_ops) July 17, 2015

So, we just have to wait…

1 Like

@mumblepins, thanks for the info!

Have to be patient and wait… :grin:

Welp. Sourceforge finally is back up (mainly), so I made some improvements. It now will install the toolchain, Netbeans for development, the Particle CLI, and all the assorted requirements for those things. It also includes a Netbeans project, so after setup, you should just be able to run Netbeans and click Build, and you’re good to go. See more info here, get it here. Tested on Win7, with nothing else really installed, and it seems to work fine. Let me know of any issues!

@mumblepins, do you know why I’m getting this error when trying to install the modules part? I’ve redownloaded your program to install everything.

That seems to be a makefile issue. I don’t know much at all about the P1 platform, so my only advice is to go into the firmware directory, and re-get the firmware from github (See below). If that doesn’t work, I’m at a bit of a loss, and would have to direct you towards someone with more knowledge about the P1 firmware.

CAUTION!!!: If you have modified any files, such as application.cpp, or added anything to the firmware directory, THIS COMMAND WILL DELETE IT! With that in mind, you can issue this to reset the firmware to the latest branch: git reset --hard origin\latest

What’s the -s for?

i thought the -S just show the main lines and not all the activity, like a suppression.

Yep, As a work around, you can build the hal project first. Otherwise there’s a fix for this in the develop branch.

@mdma, I was trying to test out the following branch: feature/i2c_timeout. I’m guessing that since this is still open this hasnt been merged into the development branch. So to get this to working I would do the below?

cd firmware/hal
make
cd firmware/main
make
?

  • cd modules
  • make clean all PLATFORM=photon APP=xxxx program-dfu