Local build on Windows 10: too long time [closed]


I’m trying to compile firmware locally by following the guide at

However it has been almost one day since I executed command ‘make all clear PLATFORM=P1’ under modules directory.

Should I keep waiting? Or is there anything wrong with my environment? I’m sure arm-none-eabi-gcc, make, crc32 and xxd are working.

Thank you guys.

@sunboss, make seems to be in an endless loop. Which directory are you running MAKE from and what are you specifying for your APP directory? Also, which gcc version are you running?

1 Like

Thanks @peekay123. Here are my settings

  1. MAKE command is triggered from firmware/modules.
  2. The gcc version is 4.9 2015q3 according to the instruction “Currently, the 4.9-2015-q3-update is recommended. The 5.3.1 version can be used now and will be used for cloud compiles starting with system firmware 0.7.0. The 5.4.x and 6.x versions are not recommended at this time.”
  3. I’m compiling firmware release v0.6.0, just the original package cloned from github. No my application yet.

You should probably just do:

make all PLATFORM=P1

I don’t think there’s a clear option. There’s clean, but you usually do that separately and you don’t need to do that on your first build as there’s nothing to clean yet. You only need to clean after updating the source from github or when changing the options (like to or from debug mode).

1 Like

@rickkas7, I just tried with clean all and it worked fine. However, I run cygwin not mingw32.

Thanks @rickkas7. Same issue when I use ‘make all PLATFORM=P1’.

Thanks. I’ll try your recipe.

Here is my report:

  1. good news: cygwin works for me
  2. do NOT contain space in the path, or else the compiler won’t work
  3. Even if I removed space from my path, MinGW32 still reports error. Anyway, I have cygwin now :slight_smile:

Thank you guys.

1 Like