Tabs are duplicated in Build

Tabs are duplicated in Build:

I just tried to recreate the issue:

  1. Added the NeoPixel library to my app.
  2. Created files called NeoPixel.{h,cpp}
  3. Removed NeoPixel library from app

Before step 3 I only had one pair of NeoPixel files. After step 3 I now have 2 pairs of NeoPixel files.

This issues has previously been reported in However, the last comment is more than 200 days ago. I am not sure what the policy is on opening old thread, so I now make a new thread on the same topic. I apologize if this is the wrong thing to do.

Try closing the browser and test again? :smiley:

Maybe @jeiden can help to take a look at this. Or even @jgoggins

Thanks for the quick reply :smile:

I tried reloading the page and also tried closing the browser. No success.

1 Like

@jdn @kennethlimcp I’ve seen this problem as well, to reproduce create a new app, add a set of files, add a library to the app and after the library add you get double tabs for each file other than the main app.


Good that we have a way to reproduce. The web development team should be able to fix that :wink:


Thank you so much @mtnscott for articulating a simple way to reproduce this issue! This issue has surfaced multiple times and though we’ve looked into it, we didn’t get far because we weren’t sure how to replicate it and weren’t sure whether it was an issue that only occurred in the production context and not dev environments. Now that we know how to reproduce this, we should be able squash this devious bug. I’ve added your “to reproduce instructions” to the existing issue we have open for that. Will ping everyone on this thread and the other one, when we push out a fix for it.

As far as workaround goes, @jdn, I was able to make the extra tabs go away by saving existing content in the duplicated tabs (in another text editor), deleting them, then refreshing the page. If others have workaround suggestions, please chime in!

After playing with libraries, my sandbox environment on now has a .ino sketch tab, and TWO each I2Cextender.cpp and I2Cextender.h tabs.

Any progress on this bug?


@suda want to create an issue for this?

@Dick Issue created.

@JohnP Until it’s fixed, refreshing Build fixes the bug.

Refreshing the web page via reload/shift-reload… (as of Aug 4, 2015) doesn’t fix it anymore…

I’m happy to announce that we’ve just deployed fix for this issue :slight_smile: Go ahead and give it a spin!