Subversion with SparkDev

I use Subversion for control of my own source code.

When I get a local working copy, Subversion drops a hidden folder (.svn) in the folder as well.

Using the Spark Dev IDE I get “app code was invalid” when I compile. If I delete the .svn folder then I can compile fine.

In my Spark Dev preferences I have Exclude VCS Ignored Paths checked and .svn is in the Ignored Names list.

I’m running 0.0.20

Jim

Hmm… I just tested and it worked for me.

Hmmm… Interesting.

It looks like your .svn folder is empty. When I click the reveal arrow mine has a number of sub folders and files in it.

I’m doing this on Mac OS X 10.9

After a reboot the same behavior exists.

Another odd thing, perhaps this is a clue (or not)… I thought to modify the Exclude VCS Ignored Paths option - just to see if it had any effect. I open Preferences, uncheck the box, then close the Preferences tab. When I open the Preferences again the Exclude option is still checked.

Jim